You can sign up to get a daily email of our articles, see the Mailing List page!
Missing Textures VS Broken Camera
Tchey commented on 5 January 2019 at 10:18 am UTC

Hi there,

I'm trying to play Adeptus Titanicus: Dominus via Proton.
https://steamcommunity.com/app/853140/discussions/

There is an important issue.

- With no option, the game runs, but the textures of the robots are missing, and i can only see the weapons, making the game hardly enjoyable.
- With some options, the textures are visible, but the camera is broken, always going fast and by itself to the bottom right corner, making the game unplayable.

Note : i do NOT have any gamepad, joystick etc plugged, only mouse+keyboard.

With Proton 3.7-8, textures broken, but camera OK
With Proton 3.16-6 Beta, textures OK, but camera broken

So, here are my results so far.

Game doesn't start at all : PROTON_NO_D3D11
Camera broken, textures OK : PROTON_NO_ESYNC=1
Camera broken, textures OK : PROTON_USE_WINED3D
Camera broken, textures OK : -force-vulkan
Pink screen, must Alt+F4 : -force-glcore

Do you know any options that could "fix" this Broken Textures VS Broken Camera challenge ?

Xpander commented on 5 January 2019 at 1:41 pm UTC

tried windowed mode? -screen-fullscreen 0 and to have borderless add -popupwindow

Whats your WM/DE? might be issue with that also

Tchey commented on 5 January 2019 at 6:24 pm UTC

Somewhat solved, going from Mint to Manjaro. Works "out of the box".

I was curious, being a Mint user for 4-5 years, to try out an Arch distro, and Manjaro seems quite well fitting my needs and tastes.

PlayX commented on 5 January 2019 at 7:39 pm UTC

You have postet this now 3 times (reddit, steam and here) and every time we said we need your specs.
The game runs out of the box on mint, too (I have Mint) but you need up2date drivers. And manjaro maybe comes with newer drivers and on mint you have install them on your own ;-)

Tchey commented on 5 January 2019 at 9:29 pm UTC

Yep, but that's not it.

Posting 3 times was done after several days of failed attempts and lack of any kind of answers (beside "unplug your gamepad").

I was up to date on my Mint system, tried many different settings, and still failed. My specs may be useful but not really relevant, as it's a common one, with a GPU supported by vulkan drivers (gtx960).

Anyway, now it works.

PlayX commented on 5 January 2019 at 10:14 pm UTC

and what was the driver version on your mint system? ;-) this is a really relevant information.
some of the new dxvk features need the 415.22 driver (nvidia) or mesa 18.3 (amd)

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Wasteland 2 with Samsai
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts