You can sign up to get a daily email of our articles, see the Mailing List page!
Ubuntu 18 ps4 controller problem
Mecova commented on 14 February 2019 at 4:49 pm UTC

My ps4 controller only register's as player2.

I can only use my ps4 controller as player1 when I remove my keyboard.

I'm guessing it has to do with this,, but it didn't work.

It also works when I have Forced Off for Steam Input Per-Game Setting, but I need that on to use the controller mapping I have.

Is there anyway for me to fix this problem or a different way for me to map my controller?

Redface commented on 15 February 2019 at 6:21 pm UTC

Is your keyboard on the list?
In case you do not know you can get the vendor and productid with the lsusb command

If lsusb knows it as a keyboard then it will be in the description field,
This is for example from my keyboard (which does not have this problem)

Bus 001 Device 003: ID 046d:c24d Logitech, Inc. G710 Gaming Keyboard

Once you see your keyboard in the output then take the first hex number after ID (046d in my example)and search for it in the udev-joystick-blacklist
and for each line for that vendor look for the second hex number (c24d in my example) if there are lines for it.

If there are not then I would try to add it, it seems the only differences between the rules are the vendor and product ids, so just copy the last 2 lines and change the vendor and product to what you have.

If they already are there then I do not know how to help. Maybe check if you have the package steam-devices installed, it contains several udev rules for the steamcontroller and other controllers.

BTW there is no Ubuntu 18, Ubuntu released twice in 2018 like every year, 18.04 in April which is a LTS with 5 years support, and 18.10 in October which is a short term release with support for only 9 months, so that it has to be updated to 19.04 within 3 months from that coming out. With 18.04 you can wait until the next LTS in April 2020, Ubuntu 20.04 :-)

Mecova commented on 16 February 2019 at 3:21 pm UTC

yep, i already tried adding my keyboard ids and installing steam-devices, but still didn't work. I'll keep looking for a solution and post it here if I get it working. Also, yea, my ubuntu is 18.04

Mecova commented on 23 February 2019 at 8:05 pm UTC

yep, already tried that, but still didn't work

Due to spam you need to Register and Login to comment.

Or login with...

Livestreams & Videos
Community Livestreams
  • RPGoodness: „Dragon Age: Origins“ (via Wine)
  • Date:
See more!
Popular this week
View by Category
Latest Comments
Latest Forum Posts