Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
Anyone play CSGO at 1440p resolution?
poincare commented on 19 March 2019 at 2:26 pm UTC

Hello all! I love CSGO's Danger Zone mode, but I recently bought a 1440p monitor and have been experiencing reproducible crashes in the mode when playing at the highest resolution. Whenever I play at 2560x1440 resolution, the game crashes at a predictable point. Whenever I play at 1080 resolution, it never crashes.

I've detailed my problem on the CSGO github, as well as in a possibly related bug report.

Just wondering if anyone would be willing to help me test this out. Here are my steps to reproduce:

  • Set CSGO resolution to 2560x1440
  • Start Danger Zone mode
  • After the warmup, select a location to deploy. Deploy and land.
  • Open the tablet and keep it open. At the moment that your first exploration bonus money would be earned, the game crashes and coredumps.

I think it has something to do with the text that gets displayed on the tablet when exploration bonuses are earned (the tablet displays the text "Exploration Bonus: $100" in green). My game crashes right before that text would be displayed. The game doesn't crash if the tablet is not open when the exploration bonus is earned.

Any testing and/or "works for me" reports would be very appreciated. I feel like I'm close to figuring out what my problem is. Thank you!!

My specs: Arch Linux, Intel i5, Nvidia RTX 2070, 1440p monitor at 144hz.

drlamb commented on 19 March 2019 at 5:39 pm UTC

I do, yes (144Hz FreeSync too!). Does it happen no matter the deploy location? I luckily haven't experienced any crashes after the most recent Linux patches.

I will attempt to reproduce this when I get home tonight.

poincare commented on 19 March 2019 at 5:44 pm UTC

Thanks, drlamb! Yes, it happens no matter where I deploy. And the crash never happens during the warmup phase, only after deploying.

WorMzy commented on 19 March 2019 at 6:22 pm UTC

I run at 2560x1440 and had no problems last time I played it. I'll run a quick round now and see if I can reproduce.

EDIT: Nope, works fine.

poincare commented on 19 March 2019 at 6:52 pm UTC

Thanks for testing, WorMzy! Can you tell me what fonts you have installed on your system? I found mine with fc-list. Since the crash seems to be triggered by text appearing on the tablet, I'm wondering if I'm missing a font or something.

WorMzy commented on 19 March 2019 at 8:27 pm UTC

That's some 2000 lines.

They're all /usr/share/fonts though, so, to make things easier, here's what packages own files in that directory on my system:

$ pacman -Qqo /usr/share/fonts gsfonts mathjax noto-fonts noto-fonts-cjk noto-fonts-emoji noto-fonts-extra openimageio steam-fonts termsyn-font ttf-dejavu ttf-hack ttf-symbola xorg-font-util xorg-fonts-encodings
steam-fonts may be of particular relevance, although I can't remember what I installed that for. ¯\_(ツ)_/¯

poincare commented on 19 March 2019 at 10:36 pm UTC

THANK YOU WorMzy!! I was finally able to figure it out. I had a couple of font packages installed that I guess were causing some problem. I removed a couple but I suspect it was ttf-ms-win10 from the AUR. I removed a few packages and now it works fine!

drlamb commented on 21 March 2019 at 1:21 pm UTC

Good to hear you figured it out! I was just about to report I encountered no issues attempting to reproduce this.

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Friday Livestream with Samsai
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts