Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
Looking Back - An experiment with Debian 5 from 2009.
Avehicle7887 commented on 22 March 2019 at 4:26 pm UTC

A few months ago the question spawned in my head "Can you run an old Linux distro on new hardware?", that question took me on a few days of experimentation. So I have a little story to share with you.

I chose Debian 5 which was released a decade ago in Feb 2009, the latest version comes with the full repo in the form of ISO files, this allowed me to build a full offline repo. The first issue I encountered was installing the distro on newer hardware due to the lack of USB drivers, if your PC doesn't have any PS2 ports or USB to PS2 adapters, it can be a hassle (especially with no ODD too) and so with my limited resources I moved to Plan B.

I took the work into a VM on my main machine, where the OS installed perfectly fine there. The next step was to try and build a modern Linux kernel, mind you the distro comes with version 2.6.26 (dinosaur) and that in no way was going to support the modern chips. I started with *kernel 3.18 which built and booted correctly, so I took it a few steps further until I hit the wall, the latest I could build was 4.4.176, quite a jump from the original one!

*I encountered a minor bump prior to Kernel compilation - The distro doesn't come with any .xz archive support so I had to build xz utils from source to extract the kernel sources in the first place.

From there it was time for the real thing, using Clonezilla I cloned the VM onto the real machine (specs at the end) and the system booted. First impressions booting Debian 5 with a modern kernel - Sound works, Ethernet Network works and USB (incl 3.0 ports) also works, the only component that I couldn't manage to work properly were the Nvidia drivers (GT1030 GPU). Still a great feat overall. Memory consumption is also quite good at just 198mb.

With that said, I also managed to boot the system with the 2.6 kernel, it gets to the desktop but again USB's didn't work and neither the sound chip. What surprised me was that the network works.

System usability - Technically speaking the software library works as expected, I tested OpenOffice, GIMP, Inkscape and a even a few games such as Abuse, FreeDoom and Airstrike, which worked as expected. Internet browsing is however a different story, browsing is a nightmare with many sites not loading properly, have missing content, while some refusing to connect at all.

A few screenshots to conclude this adventure:

image

image

System Tested on:

Intel G4560 CPU
AsRock H110M-DV Motherboard
Nvidia GT1030

damarrin commented on 22 March 2019 at 8:39 pm UTC

Heh, a nice experiment.

I did a somewhat similar thing some 10 years back. I wanted to scrap a seriously old laptop (early nineties IIRC) that didn't boot off its HDD any more, but still had data which I wanted to shred. The drive had a non-standard connector, so taking it out and attaching to a different machine was not an option. A recent Ubuntu (something like 9.04 probably) booted fine, but didn't recognise the IDE controller and the drive wasn't accessible. So I downloaded Ubuntu Warty Warthog and it worked like a charm. :-)

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • RPGoodness: „Dragon Age: Origins“ (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts