Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
Some games can't start under Proton, but can via WINE
Tchey commented on 22 March 2019 at 5:13 pm UTC

Hello,

I don't know where to ask and even less where to find a solution.

I have a few non-native games, and some of them don't work if i try to launch them via Steam Proton, but do work well if i use WINE straight from the local folder.

The issue here is that some games cannot be played if not from Steam, because they need to connect.

Example, Trailmakers, crash on launch on Proton, and seems to go fine with WINE, but then, a screen says it cannot connect to Steam and so, i can't play.

It seems to be related to Mono, not sure. Last lines from Proton, not there if i run via WINE.

ERROR: ld.so: object '/home/tchey/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. ERROR: ld.so: object '/home/tchey/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. ERROR: ld.so: object '/home/tchey/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. >>> Adding process 17489 for game ID 585420 >>> Adding process 17491 for game ID 585420 CreateDirectory '' failed: Path not found. (current dir: ) Mono path[0] = 'Z:/home/tchey/.local/share/Steam/steamapps/common/Trailmakers/Trailmakers_Data/Managed' Mono config path = 'Z:/home/tchey/.local/share/Steam/steamapps/common/Trailmakers/MonoBleedingEdge/etc'

Any idea ?

Linux Manjaro (Arch) 64bits Xfce
Intel Core i5 4590 (4 x 3,3 GHz)
MSI GeForce GTX 960 @ 2 Go
Nvidia Drivers
16 Go DIMM DDR3 PC12800
SSD Samsung 250Go

Tchey commented on 8 April 2019 at 12:11 pm UTC

Little bump.

Any idea how i could "fix" this ?

https://pix.toile-libre.org/upload/original/1554725834.jpg

QuoteTrailmakers crash on launch on Proton, and seems to go fine with WINE if i launch it from the local folder.

But then, a screen says it's not connected so, i can't play.

Steam Linux topic : https://steamcommunity.com/app/585420/discussions/0/1457328392110552846/?ctp=2

(edit : It seems i have Steam Manjaro, so i tried to install Steam Native, from the manager.

Then, i don't see how i can select -Native or -Manjaro version, it's only "Steam".

If i try to uninstall -Manjaro, it says the other "Steam" entries will be gone as well. )

serge commented on 8 April 2019 at 3:28 pm UTC

i don't know for manjaro but on archlinux, you only install steam, and then you can launch it with steam or steam-native, there is also the steam-native-runtime package for installing almost all libs required by the runtime.

Probably your game is needing .net and Proton doesn't have wine-mono for launching it.

You should use protontricks for installing the .net.

razing32 commented on 8 April 2019 at 8:17 pm UTC

Hate to be THAT guy, but what about installing a steam client under wine ?
I did that a little while back for a few games and they run quite well (Skyrim ., Fallout New Vegas)

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Friday Livestream with Samsai
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts