You can sign up to get a daily email of our articles, see the Mailing List page!
AMD dual graphics setting
adibuyono commented on 26 March 2019 at 8:44 am UTC

Good afternoon,
I recently switch to Linux Mint 19 from Windows 10.
I own a laptop ASUS X550DP which has A10-5750 with integrated graphic Radeon HD 8650G and discrete graphic cards AMD Radeon HD 8670M 2GB.
When I am using windows 10, I have AMD software Catalyst center to switch between Radeon HD 8650G and Radeon HD 8670M. I can't find such option in Linux OS.
Can someone here teach me how to switch graphic card usage in Linux OS?
Any little help are very appreciated.
Kind regards and thanks.

drlamb commented on 26 March 2019 at 12:49 pm UTC

I have zero experience with modern Linux mint but you should still be able to access prime switching.

xrandr --listproviders

DRI_PRIME=[NUM_OF_dGPU_RETURNED_ABOVE]steam

More information.

tuxintuxedo commented on 26 March 2019 at 4:07 pm UTC

DRI-PRIME is what you are looking for, as it was already mentioned. With it you can run any application on the chosen video card.

adibuyono commented on 26 March 2019 at 5:32 pm UTC

drlambI have zero experience with modern Linux mint but you should still be able to access prime switching.

xrandr --listproviders

DRI_PRIME=[NUM_OF_dGPU_RETURNED_ABOVE]steam

More information.

tuxintuxedoDRI-PRIME is what you are looking for, as it was already mentioned. With it you can run any application on the chosen video card.

I have try using DRI_PRIME, but the result seems similar or even a little worse.

xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x76 cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 1 name:ARUBA @ pci:0000:00:01.0
Provider 1: id: 0x3f cap: 0x4, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:HAINAN @ pci:0000:01:00.0


DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 4.15.0-46-generic, LLVM 8.0.0)


I use my DRI_PRIME=1 which should be discrete card, and normal run to test the benchmark,
here is the result using normal run
https://imgur.com/FojlUx6

and here is using DRI_PRIME=1 steam steam://run/203160 to run tomb raider
https://imgur.com/sae3Q9j

Note : I do let my laptop to cooldown between the tests.

Am I doing something wrong in terminal?

tuxintuxedo commented on 26 March 2019 at 5:54 pm UTC

I don't know the expected FPS with these cards, but expect somewhat worse performance than on Windows. Also, you should update your Mesa packages from the Padoka Mesa stable ppa.

adibuyono commented on 27 March 2019 at 9:31 am UTC

Update :
I have try to run Tomb Raider benchmark too in Windows using high performance setting, and the result is even worse than in Linux Mint 19.
Even though I am not sure if DRI_PRIME really did change my graphic card usage, seems like this is what my laptop can do.

Second question, can I automatically active DRI_PRIME=1 in all application without doing any setting or running terminal after a reboot? If yes, please guide me.

Thanks everyone here for the help.

tuxintuxedo commented on 27 March 2019 at 3:33 pm UTC

Using the discrete card for everything is rarely preferred because it means higher power consumption even for a text editor. If you still insist on doing that, check vgaswitcheroo.

drlamb commented on 27 March 2019 at 3:43 pm UTC

Are you using the amdgpu driver? You might need to force enable it for your card since your card is a bit older. The 8000 series is known as southern islands and they, up until recently, defaulted to using the older radeon driver. The newer amdgpu driver offered experimental southern island support at first but it's now been made the default over radeon. This change hasn't fully tricked down yet.

Verify you have amdgpu installed (which will be if you have mesa installed. Here are instructions for installing the latest mesa on Linux Mint) and test booting with the below kernel parameters.

radeon.si_support=0 amdgpu.si_support=1

Should it work better, you can make this permanent by appending this to your kernel parameters in /etc/default/grub and updating grub.

Source:
Arch Wiki

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts