Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
How to avoid screensaver when using a gamepad under Proton?
ziabice 8 Apr, 2019

Hi!
Just bought my first gamepad ever (a Logitech F310) which worked like a charm out of the box. So I started playing some native Linux games. Then I tried Proton games, in particular RiME. After a while playing (10 or 15 minutes), my screen went black: it was my screensaver that went power saving. So I had to move my mouse to come back to the game.

Is this normal? Or is just something that happens with Wine/Proton? Any fix apart from disabling the screensaver?

I'm using latest KDE and there's no option to avoid power saving when using a gamepad/joystick, from what I see...

Salvatos 8 Apr, 2019

I haven't had such issues under Mint with Cinnamon and a Dualshock 4, but I do sometimes use a Cinnamon applet which I think is called screensaver inhibitor (I'm on a different computer at the moment) for times where video players don't correctly prevent screensaving. Maybe your distro or KDE has a similar optional add-on you could download and turn on while you play?

chui2ch 9 Apr, 2019

https://store.kde.org/p/1212005/ this is the KDE version of caffeine. Hope this works for you.

ziabice 9 Apr, 2019

Thanks for the advices, in the meantime I'm testing more games...

Mullens259 18 Apr, 2019

I'm getting this as well with a generic 360 controller. I'm on Solus Mate; on the plus side Mate at least has an applet for inhibiting power saver features (Inhibit Applet).

ziabice 18 Apr, 2019

Just experienced the problem in regular WINE, maybe it's a problem with controllers in general...

no_information_here 21 May, 2019

I had this while playing Kingdoms of Amalur with a Steam Controller. My solution was just to turn of screen blanking in the system settings before playing. Worked ok, even if it wasn't elegant. (Also on KDE.)

LordDaveTheKind 22 Aug, 2019

I still don't have any answer to this issue. My workaround has been to disable the screensavers, DPMS and any form of Power Management option, including the ones defined in the Gnome Dconf.

stan 22 Aug, 2019
  • Supporter
HadBabits 23 Aug, 2019

Had this same problem with Proton games, my solution was Feral's game mode: https://github.com/FeralInteractive/gamemode

After installing, just put "gamemoderun %command%" in whatever game's launch options. On top of whatever optimizations it runs, personally I haven't messed with the config at all :P, it also keeps the screensaver from activating while the game is running. It does also seem to make some games run smoother for me (like Yakuza 0, for example).

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts