You can sign up to get a daily email of our articles, see the Mailing List page!
980ti > Radeon VII = performance drop in wine games
Tom B commented on 12 April 2019 at 1:11 pm UTC

Hi All,

I just upgraded my 980 Ti to a Radeon VII and I'm seeing very disappointing results.

In native Linux games like F1 2017 I am getting better performance (constant 60fps instead of 50-60fps at 4k).

I tried Skyrim SE (DXVK), where I was getting 50-60fps (generally it was constant 60fps with occasional drops) I am now getting 45-55fps with the same settings in the same area (4k with Godrays off and everything but shadows maxed). Carmageddon Max Damage which was running about 30fps on the 980ti now fails to launch (cant see an obvious error).

I decided to try a few older games. I launched GTA3 because I had it installed, the game runs fine but stutters when the mouse is moved. This could be an input issue, but didn't happen on the 980ti. Similarly Freelancer (which I replayed about 3 months ago so had installed) ran flawlessly on the 980ti but stutters constantly despite a high FPS on the VII.

I then tried Unreal Tournament 99 via wine. It drops down to 37 fps when there is a lot of action on screen.

For the older games I noticed that the clock speed stayed low so set

echo high > /sys/class/drm/card0/device/power_dpm_force_performance_level

even after doing this the FPS was erratic.

I am thinking it may be a configuration issue, a missing package, a WINE issue or something to do with just replacing the GPU in the same Linux installation. I uninstalled all nvidia packages and installed the amdgpu ones. Is there something I am missing? I'm going to try a fresh Arch install on a spare HDD and see if I have the same problems.

The only other change I've made is upgraded my RAM from 32gb to 64gb but I can't see what difference that makes as it's still 3200mhz.

Does anyone have any suggestions of what might be wrong?

skyrrd commented on 13 April 2019 at 8:37 am UTC

Tell us a bit more about your system.
What processor, what kernel, do you use mesa ord amdgpu-pro?

For best performance you will want to be running on latest kernel and mesa version

Tom B commented on 13 April 2019 at 1:22 pm UTC

I'm running arch with the latest kernel and mesa versions in the stable repositories.

It's an Threadripper 1950x with 64gb 3200mhz RAM.

Tom B commented on 13 April 2019 at 2:07 pm UTC

I also tried a fresh installation on a spare hard drive. Same problem, all games are a stuttery mess even though the average framerate is OK.

My only thought is perhaps it's a NUMA/UMA issue with the additional RAM. I'm going to try going back to 32gb and see if it makes any difference.

serge commented on 13 April 2019 at 2:32 pm UTC

The radeon 7 is probably too new, you should try mesa-git to have the latest code with eventual bug fix.

https://wiki.archlinux.org/index.php/Unofficial_user_repositories#mesa-git

Tom B commented on 13 April 2019 at 3:51 pm UTC

I'll try that, thanks.

One thing I have discovered is that it is not a raw GPU performance issue. If I run games on low the FPS is fine (in the 100s) but occasionally it will stutter.It only seems to be Wine that's affected. Every native Linux game I've tried has been fine.

It seems to be when loading areas for the first time which makes it worse, but it also occurs when models/textures which have already been loaded come back onto the screen. It's not consistent but is rather annoying.

Resolution/Graphics settings are irrelevant. Running skyrim on Low vs High has exactly the same result: 60fps with occasional drops when things load. And it's not just DXVk's shader cache, it happens in older games which don't use DXVK.

I've tried Proton, tkg-wine + esync and nothing helps.

Shmerl commented on 14 April 2019 at 8:42 pm UTC

Could be Threadripper issue. Did you try limiting threads to specific cores?

YoRHa-2B commented on 15 April 2019 at 11:15 am UTC

QuoteI launched GTA3 because I had it installed, the game runs fine but stutters when the mouse is moved.
This is somewhat normal if your mouse has a polling rate of more than 125 Hz, apparently this has been a known issue for half a decade. Doesn't affect all games or all setups, but when it does, it can make games completely unplayable.

Also, you pretty much have to set your CPU governor to performance on AMD CPUs, and on Threadripper it probably wouldn't hurt to disable all cores on the second die, or at least taskset -c 0-15 all your games to prevent the scheduler from going full retard.

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts