Check out our Monthly Survey Page to see what our users are running.
Lego City Undercover
Guppy 23 May 2019 at 7:33 am UTC

I bought the humble lego bundle for my son am I'm having some difficulty with the one game that was basically the reason I bought the bundle - Lego City Undercover.

I'm hoping the hivemind can help me gain some traction.

As you can see on proton db https://www.protondb.com/app/578330 the game is supposed to run very well.

But for me It just launches and immediately stops - with aparently no crash, just shuts down.

The relevant info for his machine:

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD Radeon (TM) R9 380 Series (TONGA, DRM 3.26.0, 4.18.0-20-generic, LLVM 7.0.0) (0x6939)
    Version: 18.2.8

Ubuntu 18.10


I've tried both proton v 3.16-4 & 4.2-4 with the exact same result.

Launching it from bash dosn't yield any usefull information, but I seem to recall you could add some proton options when launching games from bash that would output some more debug info - my google fu is just weak it seems as I turn up blanks.

Any tips, tricks or suggestions?

Liam Dawe 23 May 2019 at 7:37 am UTC

Are you using Mesa or the older proprietary driver? You want to be on Mesa and have it up to date.

mrdeathjr 23 May 2019 at 8:19 am UTC

In my case works some time ago but steam version dont work (in my case ask for refund in december 2018), curiously scene version works

https://www.youtube.com/watch?v=-8bpCA04apk

System Specs

Xubuntu 18.04 x64 - Kernel 4.17.12 generic (ubuntu mainline) -

CPUFreq: Performance

CPU: Core i3 8350K Tri-Core (Coffelake 14nm) 5.0Ghz + CoolerMaster Hyper T4

MEMORY: 8GB DDR4 2400mhz (4x2) Mushkin (dual channel: 37.5 gb/s)

GPU: Gigabyte Nvidia Geforce GTX 1050 OC (GP107 14nm: 640 Shaders / 40 TMUS / 32 ROPS) Windforce 2GB DDR5 7000Mhz 128Bit (110Gb/s)

MAINBOARD: ASUS Z370-P

Guppy 23 May 2019 at 12:10 pm UTC

liamdaweAre you using Mesa or the older proprietary driver? You want to be on Mesa and have it up to date.

It should be the mesa one - sorry thought that was included in the glxinfo snippet above. I've no idea really where to check driver name/info for mesa drivers so I just figured that was it

Gryxx 23 May 2019 at 4:20 pm UTC

PROTON_LOG=1 %command%
Hopefully this will provide some valuable information
EDIT: That's Steam launch option

rcgamer 26 May 2019 at 1:31 am UTC

Neither of the versions you tried were platinum on the protonDB. Try forcing 3-16-9

Guppy 29 May 2019 at 3:42 pm UTC

Just a follow up - changing to 3.16.9 (beta) didn't work either ended up having to use

PROTON_USE_WINED3D11=1 %command%

as runtime option, I've yet to change back to the current of proton to see if it helps smooth out the performance as it is a little laggy atm - but atleast it plays

for further reference here are all the options;

https://github.com/ValveSoftware/Proton#runtime-config-options

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
  • Friday Livestream with Samsai
  • RPM Flow: „Renowned Explorers“
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts