Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
Logitech G502 Hero, linux support ?
Guppy commented on 7 August 2019 at 12:10 pm UTC

I've finally had enough of gazillion tiny button on the side of my old razor and I've been looking for some thing with 3-5 side buttons of a resonable size.

I've found the G502 Hero but what worries me is that one button aparently is wired to lower dpi? can this be changed with out windows software - I've very much like for it to just send a generic "mouse button 5" instead.


Also accepting other suggestion for mice with 3-5 resonably sized buttons that don't alter mousebehaviour / or have linux support.

chui2ch commented on 7 August 2019 at 2:47 pm UTC

It seems like you should be able to configure the G502 Hero using piper/libratbag. It is listed under supported devices. https://github.com/libratbag/piper

TobyGornow commented on 7 August 2019 at 3:24 pm UTC

Solaar had a big update 12 days ago, maybe you could try it. As far as I now, you should download & install the latest version from Github, Ubuntu / Mint provides an outdated version.

https://github.com/pwr-Solaar/Solaar/releases

Guppy commented on 9 August 2019 at 2:30 pm UTC

chui2chIt seems like you should be able to configure the G502 Hero using piper/libratbag. It is listed under supported devices. https://github.com/libratbag/piper

Do you use this your self?

when using the PPA piper complains about incompatible version ( required:1, found: -1 ) piperctrl show that the 502 is found tho

nvm: seems the PPA is broken and I'll need to wait for "someone" to fix it
https://github.com/libratbag/piper/issues/379

chui2ch commented on 9 August 2019 at 4:44 pm UTC

Guppy
chui2chIt seems like you should be able to configure the G502 Hero using piper/libratbag. It is listed under supported devices. https://github.com/libratbag/piper

Do you use this your self?

when using the PPA piper complains about incompatible version ( required:1, found: -1 ) piperctrl show that the 502 is found tho

nvm: seems the PPA is broken and I'll need to wait for "someone" to fix it
https://github.com/libratbag/piper/issues/379

I use the flatpack. You may need a newer version of libratbag then what is on mint. You can compile it from source https://github.com/libratbag/libratbag. I have the g502 proteus core and it works great with it.

Guppy commented on 9 August 2019 at 6:31 pm UTC

chui2ch
Guppy
chui2chIt seems like you should be able to configure the G502 Hero using piper/libratbag. It is listed under supported devices. https://github.com/libratbag/piper

Do you use this your self?

when using the PPA piper complains about incompatible version ( required:1, found: -1 ) piperctrl show that the 502 is found tho

nvm: seems the PPA is broken and I'll need to wait for "someone" to fix it
https://github.com/libratbag/piper/issues/379

I use the flatpack. You may need a newer version of libratbag then what is on mint. You can compile it from source https://github.com/libratbag/libratbag. I have the g502 proteus core and it works great with it.

Think I'll a few more days for the PPA - I've broken too many a system by mixing packages with self built ^^

chui2ch commented on 9 August 2019 at 7:07 pm UTC

Guppy
chui2ch
Guppy
chui2chIt seems like you should be able to configure the G502 Hero using piper/libratbag. It is listed under supported devices. https://github.com/libratbag/piper

Do you use this your self?

when using the PPA piper complains about incompatible version ( required:1, found: -1 ) piperctrl show that the 502 is found tho

nvm: seems the PPA is broken and I'll need to wait for "someone" to fix it
https://github.com/libratbag/piper/issues/379

I use the flatpack. You may need a newer version of libratbag then what is on mint. You can compile it from source https://github.com/libratbag/libratbag. I have the g502 proteus core and it works great with it.

Think I'll a few more days for the PPA - I've broken too many a system by mixing packages with self built ^^
Could still try the flatpack. If it needs a newer version just uninstall it.

MrNilsson commented on 11 August 2019 at 6:25 am UTC

I think the Flatpak is also broken.
image

Guppy commented on 12 August 2019 at 4:56 pm UTC

Seems the PPA maintainer is missing in action (libratbagd has failed to build 4 weeks ago), guess I'll be removing the PPA and installing from source

Guppy commented on 14 August 2019 at 9:01 am UTC

Can't even manage to compile piper on ubuntu - I'm missing pygobject3 development packages, and I can't for the life of me figure out what the package name is

iwantlinuxgames commented on 14 August 2019 at 10:59 pm UTC

GuppyCan't even manage to compile piper on ubuntu - I'm missing pygobject3 development packages, and I can't for the life of me figure out what the package name is

python3-gi-dev

  Go to:

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
  • The Dark Eye: „Drakensang“ (via Proton)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts