Check out our Monthly Survey Page to see what our users are running.
ARK: Survival Evolved suddenly crashing upon launch.. Any advice?
Duck Hunt-Pr0 10 March 2020 at 5:57 pm UTC

The game ran perfectly fine for a few days after i'd bought it, so either they messed up something in one of their previous updates, or something's fubared on my end.

Today i've tested moving from mesa to building mesa-git , with no apparent success in getting it to run past the initial loading splash with that either; It still crashes at launch with the dump log posted below:

QuoteGenerating report for minidump

Application version 1.0.0.0
... built from changelist 0

OS version Linux 5.5.8-zen1-1-zen (network name: abox)
Running 8 x86_64 processors (16 logical cores)
Exception was "SIGSEGV: invalid attempt to access memory at address 0x00000003"

<SOURCE START>
<SOURCE END>

<CALLSTACK START>
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc2f32] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x9ae23f] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc3c64] + some bytes
Unknown!/usr/lib/libpthread.so.0(+0x14800) [0x7fd2a59a1800] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc407b] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1d13f6c] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1d06795] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x2574799] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x37387a9] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x37369d2] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x38a1e18] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x38a8d36] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c9208d] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c918e6] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x258ba8a] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x259848d] + some bytes
Unknown!/home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c8c84f] + some bytes
Unknown!/usr/lib/libpthread.so.0(+0x946f) [0x7fd2a599646f] + some bytes
Unknown!/usr/lib/libc.so.6(clone+0x43) [0x7fd2a50ff3d3] + some bytes

Assertion failed: Assertion failed: GRHIVendorId != 0 [File:F:\build\trunk\Engine\Source\Runtime\RHI\Private\RHI.cpp] [Line: 539]



[Callstack] 02 0x0000000001cc2f32 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc2f32]
[Callstack] 03 0x00000000009ae23f /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x9ae23f]
[Callstack] 04 0x0000000001cc3c64 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc3c64]
[Callstack] 05 0x00007fd2a59a1800 /usr/lib/libpthread.so.0(+0x14800) [0x7fd2a59a1800]
[Callstack] 06 0x0000000001cc407b /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1cc407b]
[Callstack] 07 0x0000000001d13f6c /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1d13f6c]
[Callstack] 08 0x0000000001d06795 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1d06795]
[Callstack] 09 0x0000000002574799 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x2574799]
[Callstack] 10 0x00000000037387a9 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x37387a9]
[Callstack] 11 0x00000000037369d2 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x37369d2]
[Callstack] 12 0x00000000038a1e18 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x38a1e18]
[Callstack] 13 0x00000000038a8d36 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x38a8d36]
[Callstack] 14 0x0000000001c9208d /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c9208d]
[Callstack] 15 0x0000000001c918e6 /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c918e6]
[Callstack] 16 0x000000000258ba8a /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x258ba8a]
[Callstack] 17 0x000000000259848d /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x259848d]
[Callstack] 18 0x0000000001c8c84f /home/username/.local/share/Steam/steamapps/common/ARK/ShooterGame/Binaries/Linux/ShooterGame() [0x1c8c84f]
[Callstack] 19 0x00007fd2a599646f /usr/lib/libpthread.so.0(+0x946f) [0x7fd2a599646f]
[Callstack] 20 0x00007fd2a50ff3d3 /usr/lib/libc.so.6(clone+0x43) [0x7fd2a50ff3d3]

<CALLSTACK END>

0 loaded modules

Report end!

PS: Yes, yes, Both 'reinstall' and 'verify files' have been tried already; No change.

I'm thinking it MIGHT potentially be cause by somwhat low diskspace at launch, though i have absolutely no idea.

Last edited by Duck Hunt-Pr0 on 10 March 2020 at 6:15 pm UTC

Duck Hunt-Pr0 10 March 2020 at 9:22 pm UTC

How is it, that some people seem to be far too apt at prowling Debug & Issue threads; Pretending to be "tech savvy"; though merely pointing out the problem already in question, but with no actual insight or clue to provide to anyone. .. ?

All but farting out some "You'll just have to.." , pretending that's some sort of help or answer or input towards a fix .. Not even a sensible suggestion or advice provided.. ..telling me what to do..

Don't those people realize they contribute absolutely nothing but useless noise in a support thread?

#WhatGrindMyGears #madattheinternet




Last edited by Duck Hunt-Pr0 on 10 March 2020 at 9:41 pm UTC

stan 12 March 2020 at 6:57 pm UTC
  • Supporter
  • Top Supporter

I bought it recently and it does crash on launch. I had to switch to the experimental beta to have it run, but even then the menu freezes for a very long time regularly. I was still able to play (once in the game there are no freezes anymore). But in the end I reinstalled the game with Proton enabled in order to have less crappy graphics.

(With an nvidia gpu.)

Duck Hunt-Pr0 12 March 2020 at 7:30 pm UTC

I'll give that beta a go

Thanks!

Last edited by Duck Hunt-Pr0 on 12 March 2020 at 7:32 pm UTC

Duck Hunt-Pr0 13 March 2020 at 12:03 am UTC

stanI bought it recently and it does crash on launch. I had to switch to the experimental beta to have it run, but even then the menu freezes for a very long time regularly. I was still able to play (once in the game there are no freezes anymore). But in the end I reinstalled the game with Proton enabled in order to have less crappy graphics.

(With an nvidia gpu.)

Well what do you know, switching to the (experimental) Beta seems to work brilliantly! (i at least get to the main menu now. will report on any in-game crashing.) Take that, any "You'll just have to.." !

I thank you again! Skål!

(amd gpu here)

Last edited by Duck Hunt-Pr0 on 13 March 2020 at 12:36 am UTC

activate2010 3 April 2020 at 10:23 pm UTC

I just tried it today and I have it running with the qolbeta_public build. No idea what the difference is to the experimental beta but both seem to work

mastervip3123 5 April 2020 at 11:05 pm UTC

Here it is working perfectly ..
Solution: Properties >>> Beta >>> experimental

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
None currently, submit yours here!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts