Join us on our own very special Reddit: /r/Linuxers
Elite: Dangerous
StraToN 15 Mar

Hey everyone!

I'm creating this thread for Elite: Dangerous. I know this may look like a support thread, but since sounds more specifically like a Proton issue.
This game was working for me on my laptop until recently using Proton. However since a few time, the game does not run anymore, not the launcher. I tried using Proton 4.11 and 5.x, same result

Is anyone observing the same as I do ?
Thanks!

scaine 21 Mar

I bought E:D a few months back, but couldn't get it to run at all. I can't remember what versions I tried, so not much help to be honest, but it was an easy refund for me. If this thread takes off with any advice for getting it running, I might give it another try.

jens 21 Mar

Just tried my installation here, still runs just fine. I have the Steam version and use SteamPlay/Proton for ED.
I've setup protontricks and with that I installed dotnet40 into the prefix (`protontricks 359320 dotnet40 win7`). Note that you need to start the game once before running protontricks for having an existing prefix folder.
My launch options are `WINEDLLOVERRIDES=rundll32=d gamemoderun %command%`, though the dll override is just to prevent a rundll message box in case the prefix got updated.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.


Or login with...