Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
Trying to get Dragon Age: Inquisition to work properly...
sceneturkey 25 Jul, 2020

This is pretty darn specific so I haven't seen any forum posts about this. I run Manjaro XFCE.

So I own Dragon Age: Inquisition on Origin and not Steam because I got it through a reseller (resellers are bad, I know). So I had to install Origin through Lutris to get the game to install. The game installs just fine, but because the game requires being launched through the Origin app, I can't set any extra toggles like gamemode or ACO shaders, so the game doesn't run that great.

Besides that, I like to play with a Dualshock 4 controller, but the game isn't recognizing it. I've read this is just a problem with Origin and that I should try launching Origin through Steam to get the controller profiles loaded. Well, as it turns out, Linux Steam doesn't load Origin and it keeps crashing because there isn't a way to use wine by itself through Steam. I tried loading winesteam through Lutris and got Origin to run on there, but it runs a different Origin launcher than before so my game isn't loaded on there. Trying to add the game files where it's located alerts me that the "file extension is too long" and that I should install it somewhere else, but the problem is that I had to jump through hoops to get this to install and run so the extension is going to have to be long.

I tried fixing the DS4 not working problem by installing a DS4 premade Linux profile called ds4drv, but it's not doing anything.
Could someone give advice on how to get the game to run better through Lutris and also to get my DS4 controller working with the game?

Grazen 25 Jul, 2020

Haven’t played this in a while but there’s a DA:I script in Lutris. Run that instead then install Inquisition from Origin. Make sure that you install all of the Origin dependencies. It worked for me (well... a few years ago now) with the controller, though I was using an Xbox Controller.

sceneturkey 25 Jul, 2020

I did the install from there. I even changed the wine config to Windows 10 instead of 8.1 but it runs terribly.

Beamboom 1 Dec, 2020

Any new experiences on this one? I run Inquisition through Steam and it runs perfectly - except for the controller. I have to play with keyboard+mouse and that *sucks* in games like these.

Anyone know of a fix? The result from googling this is depressive, so I think I know the answer to this one. But one can always hope!

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.