You can sign up to get a daily email of our articles, see the Mailing List page!
Need help running Cogmind
Acrophobic 22 Sep, 2020
Hi everyone. I've just bought Cogmind from Steam. Unfortunately, whenever I run it from Steam it always failed to launch. However, when I run it directly using wine Cogmind.exe it works properly (Alt-Tab not work though).

Here is my PC data :
  • OS Manjaro Linux with kernel 5.8.6

  • Wine version 5.16 staging

  • Proton 4.2.9

I've put the log from Steam in Pastebin.

Any idea how to fix it? Thanks!
Acrophobic 23 Sep, 2020
I found how to fix it. In case anyone face the same issue, this issue is happened because somehow Steam run Cogmind using native libraries instead of Steam runtime libs. To fix this, I force Steam to use runtime libs by using following command :

STEAM_RUNTIME=1 %command%

Now everything works without problem.

Last edited by Acrophobic on 23 September 2020 at 7:27 am UTC
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams