Join us on the Linux Gaming community on Lemmy, the federated open source alternative to Reddit.
Galactic Civilizations III--seems like can be made to work, anyone know how?
Purple Library Guy 15 Nov, 2020
I finally decided to actually use Proton for something, but my current success level is . . . brief.
GalCiv III does start to start . . . it pops up a launcherish thing, so I click "Play", and then it fills the screen with the usual "this is the publisher" splash, and then it dies and pops up a little window saying it crashed. This happens with both versions of Proton that Steam makes available to choose.

It's Silver in ProtonDB, with various people, especially recently, saying it runs fairly decently and not mentioning any workarounds. All the posters involved seem to be running NVidia and I'm using AMD, no idea if that has anything to do with it.

Anyone have any notions what I could try?

(Incidentally, and this is hard for even me to believe considering how long I've been hanging around here yacking about articles, this is not only my first attempted use of Proton, but also my first GoL forum post)
eldaking 15 Nov, 2020
When I tried it (years ago already), IIRC it started and I could even start a game... but most of the graphics didn't show - no planets, no ships, and I think a lot of the UI - to the point of being unplayable. So, graphics problems are probably a likely point to try - try using WineD3D and DXVK, esync, checking drivers, maybe tinkering with settings (in a settings file if there is one). (My graphics card was pretty old, Intel HD4000, with incomplete/unofficial Vulkan support only, and I think the game doesn't have an option to use opengl like many others do. But on Windows it worked and met the prereqs).

Also, all reports indicated it was extremely buggy with wine/proton (at the time at least), so I gave up at the time; it was already pushing the limits of what my laptop could run on Windows. Stardock's new-ish games are all very borked on Linux, so probably an engine issue.
Trias 15 Nov, 2020
Quoting: Purple Library GuyAnyone have any notions what I could try?

Congratulation on your first forum post! :).

Tried to launch the game myself. It sure buggy on Proton 5.0-10 and 5.13-2 (at lest on AMD), but with latest Proton-GE (Proton-5.9-GE-8-ST) everything looks fine. Played for 10 minutes, made a few turns. Intro also works. Maybe try this?

Edit: Oh, you likely knew, but since it's your first use of proton - to use Proton-GE you need to extract it into ~/.steam/root/compatibilitytools.d/ (Create the folder if it doesn't exist) and restart Steam.

Last edited by Trias on 15 November 2020 at 9:38 pm UTC
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts