Join us on our own very special Reddit: /r/Linuxers
Proton 5.13.4 doesn't load games, but proton-5.10 works great
syxbit 8 Jan
If I select Proton-5.13.4 and click 'play', nothing loads. After 2-3 seconds, the 'play' button goes back to normal. If I select Proton-5.10, games boot fine. I've tried uninstalling and fully deleting Proton-5.13 followed by reinstalling, but it hasn't helped. I'm eager to try newer and newer proton versions, and I'm guessing this isn't a widespread issue. How could it be, Proton-5.13 doesn't boot a single game. Surely Valve would be aware if it were that bad. That leads me to believe it's local to my system. It got corrupted on my system (though that wouldn't explain why an uninstall/reinstall wouldn't have have fixed it.

Has anyone else encountered this? Any ideas?
This topic has an answer marked - jump to answer.
CatKiller 8 Jan
5.13 uses the new containerisation system - Soldier. Liam's written some things about it. That containerisation can cause problems for some people's configurations.
syxbit 8 Jan
interesting. I'll take a read.
In case it matters, I'm running Steam through flatpak on Arch Linux
CatKiller 8 Jan
AFAIK, Soldier doesn't work at all in a Flatpak: it's a container in a container. It's something they're looking at for the future. There's a proton-experimental that has fixes for some of the things, but it's not something I've tried personally. Heck, I haven't tried the normal 5.13 personally yet.
whizse 8 Jan
  • Supporter
Quoting: syxbitinteresting. I'll take a read.
In case it matters, I'm running Steam through flatpak on Arch Linux
Bug report here,

Looks like there's some progress on getting it working with Flatpak again:
QuoteThe eventual solution is likely to require updated versions of both Flatpak (I'm hoping to get the necessary code included in Flatpak 1.10) and the SteamLinuxRuntime_soldier depot.
syxbit 9 Jan
This is helpful. Thanks.
Flatpak is amazing for Steam, and means I don't need the bajillion 32-bit packages. I think overall I'm happy with the tradeoff, at least right now.
The_Aquabat 15 Jan
I don't have steam flatpak, but I have the same problem, it used to work at some point.... Soldier runtime it's still very unstable I hit several bugs, one was new Proton not working if gtk-nocsd (gtk no client side decoration) is installed and then Proton not working also if you have installed the OpenCL component of the amdgpu pro driver (I use the openCL propietary part of the AMD driver for some programs like Darktable and Blender). Now again it's started not working again, afaik the problem is that Soldier Runtime expects a "pure" debian-like setup without any ppa's packages or any other none standard configuration. I use a lot of ppas, so hard to say what the problem is. For now Proton GE 5.21 works just fine for me.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.