Check out our Monthly Survey Page to see what our users are running.
Steam Cannot See Library Folders
14 14 Feb
At some point within the last few days, it may have been the day I ran system updates, my Steam library of installed games appeared much smaller than normal. When I went to start up a particular game, the button in Steam said to "Install" it instead of "Play" it. I went into the Steam library settings and it showed that two of my library folders had 0 games installed. I can access these drives at their normal paths outside of Steam normally and read/write files. The games are there. So I tried to remove the two broken library folders and re-add them. But now Steam won't even populate any folders under my home directory. That's where the drives are mounted, so I can't add them to Steam. What's weird is one of the drives did not break even though it is mounted with the same config in fstab, has the same folder permissions, and also lives in my home directory. It doesn't make sense.

link

link

As you can see, the Steam dialog does not see that my home dir has any sub folders. If I tell it to create a new folder and type in an existing folder, it will err and say it already exists! You know, maybe that will be my backup workaround -- I'll tell Steam to create a new folder and then move my Steam files into it. I wonder if it will still say 0 games though.

- My home directory has 700 permissions and no special acl.
- The drives (both working and not working in Steam) are mounted in fstab as ext4 and "defaults" for options.
- Running Arch Linux and Plasma.
- Steam is installed from the normal Arch repo, not flatpak.

I have rebooted multiple times. I reinstalled Steam over itself. I tried another kernel version. I don't get it.

EDIT:
When trying to install a game, Steam suggests adding a library folder to the missing drives. So it knows they're mounted there.

link

Last edited by 14 on 14 February 2021 at 4:30 pm UTC
This topic has an answer marked - jump to answer.
14 5 Mar
I still have this problem, but I learned something new today. If I create a new folder inside my home directory and then copy an existing Steam library folder (that Steam can't see!) into the new folder, and then add that new path to my Steam library settings, Steam can see it and instantly sees the installed games there.

So, what's the deal. There is something with old versus new folders in my home path. I have compared permissions, umask, attributes, extended attributes, and encoding. I have blown away everything Steam related and reinstalled it. Doesn't help.

This means I should have a workaround. I can comment out my mounted drives in fstab, reboot, recreate the folders they're mounted to, re-enable them in fstab, then reboot again. That should fix this issue. But why does that work? Why is only Steam affected? What caused this? The ideas I have are rsync and borg backups run as root. I also cloned my system drive (with home dir) long ago using dd when I upgraded my drive.
14 6 Mar
Alright, here is the fix. I don't know what caused the problem, but after many hours of trial and error, I found that I needed to `touch` the directories that Steam could not see inside. What the hell!

I have a little more details in this Github issue post that was not really the same issue as the OP but it was the same issue as one of the commenters.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts