You can sign up to get a daily email of our articles, see the Mailing List page.
xhost error when entering distrobox ubuntu
robotBison Sep 26, 2022
Hello there,

I am a longtime dabbler in Linux as a very casual / intermediate user and have recently been attempting to set up a key remapper for my razer orbweaver keypad on the steam deck.

I previously had accomplished this by turning off read-only mode and installing pacaur package manager. I learned about distrobox here and have installed it using the instructions listed in this article but am running into the following issue when entering my ubuntu container:


I am hoping someone here with deeper understanding can help me figure out what's going on, I've added the linexhost +si:localuser:$USER to my .bashrc, and it doesn't seem to be working.

(deck@steamdeck ~)$ distrobox enter ubuntu-22-10 
Container ubuntu-22-10 is not running.
Starting container ubuntu-22-10
run this command to follow along:

 podman logs -f ubuntu-22-10

 Starting container...                           [ OK ]
 Installing basic packages...                    [ OK ]
 Setting up read-only mounts...                  [ OK ]
 Setting up read-write mounts...                 [ OK ]
 Setting up host's sockets integration...        [ OK ]
 Integrating host's themes, icons, fonts...      [ OK ]
 Setting up package manager exceptions...        [ OK ]
 Setting up dpkg exceptions...                   [ OK ]
 Setting up apt hooks...                         [ OK ]
 Setting up sudo...                              [ OK ]
 Setting up groups...                            [ OK ]
 Setting up users...                             [ OK ]
 Setting up groups...                            [ OK ]
 Setting up users...                             [ OK ]
 Executing init hooks...                         [ OK ]

Container Setup Complete!
bash: xhost: command not found
straws Nov 8, 2022
Were you able to find a solution to this? I am also getting this error.
Echelon427 Jan 12, 2023
I fixed this by installing
Quotex11-xserver-utils
on your distro that was created. For instance, after entering your ubuntu distro with
Quotedistrobox enter ubuntu-22-10
, run
Quotesudo apt-get install x11-xserver-utils
. The
Quotexhost +si:localuser:$USER
command that is in your
Quote~/.bashrc
should now work whenever you enter your distro.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register


Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.