Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone with no article paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.

Proton GE, the community-built version of Proton has a fresh major upgrade with Proton-6.10-GE-1 out now. This is also a recommended upgrade by the developer. As a reminder, if you didn't see it, as of a recent version of Proton GE you may need to remove current game prefixes setup by it to allow the games to work properly. More on that in the previous article with instructions on how to do so.

If you're not clear on what Proton and Steam Play are, be sure to check out our constantly updated dedicated page. It's a special compatibility layer for running Windows games and apps from Steam on Linux.

Here's the main updates for Proton-6.10-GE-1:

Added UE4 preinstall workaround for Necrumunda
Added UE4 preinstall workaround for Deliver us the Moon
Added fix for Guilty Gear XX Accent Core R 2 hang
Added Horizon Zero Dawn animations patch
Added FarCry regression hotfix
Origin seems to be much more stable/reliable now in regards to installation and launching
Added staging bcrypt patches rebased on top of proton rdr2 patches (allows Steep online mode to work again)
Added proton nvapi updates
Added proton QPC performance patches (should help with fps regression)
Added proton LFH performance patches (should help with frame times)
dxvk updated with proton latency fixes
vkd3d updated with proton latency fixes
faudio updated
steamclient updated with splitgate fix

To use it here's what you do:

  1. Download the Proton-6.10-GE-1.tar.gz file from the release notes.
  2. If this folder does not exist, create it:~/.steam/root/compatibilitytools.d/
  3. Extract the archive downloaded in Step 1, and place the contents into the above directory.
  4. Restart Steam if it's open which refreshes the Steam Play list for Proton-6.10-GE-1 to show up.
  5. Right click on your game, go to Properties, Compatibility and ensure the box is ticked named "Force the use of a specific Steam Play compatibility tool" then select it from the dropdown box that appears.
Article taken from GamingOnLinux.com.
19 Likes , Who?
We do often include affiliate links to earn us some pennies. We are currently affiliated with GOG and Humble Store. See more here.
About the author -
author picture
I am the owner of GamingOnLinux. After discovering Linux back in the days of Mandrake in 2003, I constantly came back to check on the progress of Linux until Ubuntu appeared on the scene and it helped me to really love it. You can reach me easily by emailing GamingOnLinux directly.
See more from me
1 comment

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.