You can sign up to get a daily email of our articles, see the Mailing List page.
No main menu in Master of Orion
jgacas 19 Nov, 2016
Hi community,

I need help with Master of Orion. Bought the game after version 51.2 was released and immediately had a problem with missing main menu (game loads but there is no main menu, only background image of a planer, so I cannot play the game at all). Latest game version 51.3 also has same problem. But launch version 49.5 works as expected.

I contacted tech support, sent them log files, and in the end received a message that the issue was escalated to QA team. I am not the only one that has this problem, several people mentioned this in the comments of latest release notes.

My spec:
Ubuntu Gnome 16.04
Intel Core 2 Duo E8300
Nvidia GTX560, driver version 367.57
8GB RAM

Player.log file from version 51.3 which does NOT work https://paste.ee/p/90hMC .
Player.log file from version 49.5 which does work https://paste.ee/p/mzoiP .

I highly appreciate any help.

Edit: added links to log files
SuperTux 6 years 23 Nov, 2016
I have been having problems even launching the game and from what I can tell they are using some funky version of Mono.

Not sure if this helps, but maybe worth a mention.
jgacas 8 Dec, 2016
Just wanted to update this topic because there is a progress regarding missing menu issue. The problem seems to affect older CPUs because at some point after initial release, ver. 49.5, devs updated plugin for UI middleware they use in unity3d engine but did not use compiler flags to optionally include support for SSE4/AVX set of instructions. So game failed to display main menu on every CPU that does not support those instructions.

Here is a thread with detailed information how to replace that plugin with custom build provided by developers - http://steamcommunity.com/app/298050/discussions/1/154642901281000502/ .

This patch is not yet in a official release.
Liam Dawe 8 Dec, 2016
Looks like they released the working file here: http://steamcommunity.com/app/298050/discussions/1/154642901281000502/?ctp=3#c154642901282087036

Seeing reports of it working for people.
jgacas 8 Dec, 2016
Yes, I tried custom build and it works! Finally I can play the game.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: Liberapay or PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.