You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
  Go to:
Dying Light refuses to launch
DamonLinuxPL commented on 28 October 2017 at 11:26 pm UTC

ysblokje
DamonLinuxPLAnd it works for some time. After few new mesa patches, mesa devs broke it again, and it is still broken (until today).

Not sure if you meant that it should work from today onward, but it's still broken for me today (29-10-2017) on arch.


No. I mean it worked few months ago, when mesa developers released patch for this and then it worked. After few patch they broke it again and still is broken. So if u trying it today it is still broken.

tuubi commented on 29 October 2017 at 9:15 am UTC

DamonLinuxPL
tuubiIn this case it was actually due to a known bug in the engine.

Nope.
Yep.

DamonLinuxPLAlso calling this as game bug is misunderstanding.
Did you even read the link I gave you? Here's the relevant quote from the Mesa patch notes:
QuoteThis fixes the long-standing problem with Dying Light where the game would produce a black screen when running under Mesa. This happened because the game's vertex shaders redeclare gl_VertexID, which is a GLSL builtin. Mesa's GLSL compiler is a little more strict than others, and would not compile them:

error: `gl_VertexID' redeclared

The allow_glsl_builtin_variable_redeclaration directive allows the shaders to compile and the game to render. The game also requires OpenGL 4.4+ (GLSL 440), but does not request it explicitly. It must be forced with an override, such as MESA_GL_VERSION_OVERRIDE=4.5 and MESA_GLSL_VERSION_OVERRIDE=450.
The game isn't perfect, and neither is its OpenGL (or GLSL) code. I can't blame Techland for not supporting a distro they never promised support for though. Also not supporting Mesa is a damn shame, but they're not the only ones.

This said, I'm currently playing through the game and having tons of fun. Too bad not everyone gets to enjoy it.

Furious commented on 29 October 2017 at 7:13 pm UTC

tuubi
DamonLinuxPL
tuubiIn this case it was actually due to a known bug in the engine.

Nope.
Yep.

DamonLinuxPLAlso calling this as game bug is misunderstanding.
Did you even read the link I gave you? Here's the relevant quote from the Mesa patch notes:
QuoteThis fixes the long-standing problem with Dying Light where the game would produce a black screen when running under Mesa. This happened because the game's vertex shaders redeclare gl_VertexID, which is a GLSL builtin. Mesa's GLSL compiler is a little more strict than others, and would not compile them:

error: `gl_VertexID' redeclared

The allow_glsl_builtin_variable_redeclaration directive allows the shaders to compile and the game to render. The game also requires OpenGL 4.4+ (GLSL 440), but does not request it explicitly. It must be forced with an override, such as MESA_GL_VERSION_OVERRIDE=4.5 and MESA_GLSL_VERSION_OVERRIDE=450.

The game isn't perfect, and neither is its OpenGL (or GLSL) code. I can't blame Techland for not supporting a distro they never promised support for though. Also not supporting Mesa is a damn shame, but they're not the only ones.

This said, I'm currently playing through the game and having tons of fun. Too bad not everyone gets to enjoy it.

Can you help me with this one? I'm not sure how do I use the said directive "allow_glsl_builtin_variable_redeclaration" ? Is it a launch option in steam? What's the syntax then?

tuubi commented on 29 October 2017 at 9:13 pm UTC

FuriousCan you help me with this one? I'm not sure how do I use the said directive "allow_glsl_builtin_variable_redeclaration" ? Is it a launch option in steam? What's the syntax then?
That's not something you should have to deal with yourself. But if you're on Mesa 17.2 or later and the rule is missing from your /etc/drirc, I guess you should add it there. According to the patch it should look like this:
<application name="Dying Light" executable="DyingLightGame"> <option name="allow_glsl_builtin_variable_redeclaration" value="true" /> </application>

If something else has broken since the patch like DamonLinuxPL suggests, this won't help you at all. And remember, this is only relevant if you're running an AMD GPU on Mesa.

lunix commented on 10 November 2017 at 9:02 pm UTC

tuubi
FuriousCan you help me with this one? I'm not sure how do I use the said directive "allow_glsl_builtin_variable_redeclaration" ? Is it a launch option in steam? What's the syntax then?
That's not something you should have to deal with yourself. But if you're on Mesa 17.2 or later and the rule is missing from your /etc/drirc, I guess you should add it there. According to the patch it should look like this:
<application name="Dying Light" executable="DyingLightGame"> <option name="allow_glsl_builtin_variable_redeclaration" value="true" /> </application>

If something else has broken since the patch like DamonLinuxPL suggests, this won't help you at all. And remember, this is only relevant if you're running an AMD GPU on Mesa.

It seems like mesa is truly broken with DL again...

bintsmok commented on 28 November 2017 at 5:40 am UTC

On my PC, the game would launch and I would see the loading bar at the bottom of the screen. However, intro scene is blank but there is sound. Can't get to the main menu. My PC does.not lock up because I can Alt + F4 to close the game.

Ubuntu MATE 17.10
Mesa 17.3.0-rc4
Radeon RX 480 8GB
Intel Core i7 7700

What should I do?

bintsmok commented on 1 December 2017 at 6:19 pm UTC

Tried this in the launch option

MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%

Still can't play the game

devland commented on 8 December 2017 at 10:11 am UTC

Someone on reddit suggested using the Steam snap to run Dying Light, as it bundles all the runtime dependencies from ubuntu.

I haven't tested it yet, but it appears to work.

skyrrd commented on 9 December 2017 at 10:54 pm UTC

about to try on a fresh install of fedora27. if this is going to work i really need to get snapd running on gentoo

skyrrd commented on 9 December 2017 at 11:31 pm UTC

the good news: its really playable
image
the bad news: changing settings ingame causes a crash to desktop, so i'm stuck with medium settings.

right now i'm running with radeon module on 4.13 kernel. performance is quite ok (75fps was a higher spike. it tends to hover at about 50)

i'll see what i can do about settings, if savegames work and how it runs with amdgpu on 4.15_rc2

stay tuned

UPDATE:
after several tries i was able to adjust my settings to 1080p and everything maxed out.
getting avg 60fps with my r9 290 (overclocked bios with 1150gpu/1550mem) and never dips below 40 so i would say it's pretty playable. can't say how performance will be in other areas, this is in the slums.

savegames are working as well

thanks so much for the tip


UPDATE2: sadly my steam controller is not working with this methode
here's with 4.15_rc2 kernel: https://imgur.com/a/hsKJ9

if anyone knows how to get steamcontroller or at least xbox360 controller working with steam snap package, pls let me know

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Official Livestreams
  • Oxygen Not Included & Rust Christmas Patch!!
  • Date:
Community Livestreams
  • Story Time: "Black Mirror 2" (via Wine)
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook