You can sign up to get a daily email of our articles, see the Mailing List page!
Steam controller wireless stopped working (Ubuntu16.04 & 17.10)
Julius commented on 1 November 2017 at 3:31 pm UTC

Strange issue... I had my steam controller working nicely on my Kubuntu16.04 system up until end of September or so. Then I didn't use it for a while, but when I tried again mid of October it was always only blinking and turning off afterwards again (no wireless connection).

Then I tried with the USB cable and it works fine...

I have the updated udev rule set as described, I updated everything, I even checked in /dev if the usb devices for the usb wireless dongle show up (they do)... but nothing makes it work.

I also tried on another device with Ubuntu17.10, but same issue.

Anyone got an idea?

Feda commented on 1 November 2017 at 3:49 pm UTC

My steam controller stopped working with wireless over a year ago.

stud68 commented on 1 November 2017 at 6:21 pm UTC

Happened to mine before. It was the dongle was broken.
Opened a request with steam and they sent me a new one for free.

Julius commented on 1 November 2017 at 7:03 pm UTC

Hmm, does it break just like that from sitting on a shelf not being used?

It also still seems to be recognized by Ubuntu as various USB devices.

But I just tried with Windows10 on another machine where it also seems to have stopped working... not so easy for me to get a replacement though for various reasons

Is there maybe a way to reflash the firmware or something like that which might fix it?

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Story Time: „The Book of Unwritten Tales 2“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts