You can sign up to get a daily email of our articles, see the Mailing List page!
Brütal Legend - Weird Stutter / Frame Skipping problem
Dysomnia 1 Apr, 2018
Hi there,

I've been trying to replay Brütal Legend for a while now, but I can't seem to get it to run smoothly on my current system :( ->

i5 3570
GTX 1070 390.25
16GB DDR3 1600
Linux Mint 18.3

This rig manages to run a lot of way more demanding games on 1080p High (for example Everspace, The Talos Principle, Shadow of Mordor, Layers of Fear or more recently The Signal from Tölva) at or around 60fps.

The game looks like it could run smoothly, but every half second or so, there's an unfortunately very noticeable "hiccup" that makes it unplayable. It's like some frames are being dropped at a regular fixed interval. I could bet that this has something to do with how the game is built and most of the animation being hard-coded to a 30Hz update cycle (because consoles), but I've run out of options in trying to tweak this thing.

Everything that works with other games that display some sort of issue in this ballpark (Compositing on/off, VSync, frame capping with libstrangle...) had no effect. All in-game options also didn't do shit :(. There are apparently also windows users with these kinds of problems, and there are solutions, but these don't apply because it's all about tweaking some nvidia driver options (pre-rendered frames for example) that just aren't present in Linux :\.

What's weird is that it used to work - I had no problems when I played the game the first time a few years ago - system being the same except for the GPU (GTX 660) and the OS version (Linux Mint 17.x).

I'm not really expecting answers to be honest - it's a game from 2009, even if the Linux port is more recent. But maybe there's super smart person around in these forums that can tell me "Well that's easy, you just need to add the option "No fucking stutter bro" to your xorg.conf and it'll work!"

Any hints appreciated :).
Leopard 3 Apr, 2018
Try 384.111 driver.
Anza 4 Apr, 2018
Sounds bit like the problem I had with Borderlands 2. In my case problem was that when GPU went to power saving mode, few frames were dropped. I think it was switching between performance levels all the time.

If that's problem in your case, here's how to turn on high performance mode. Open NVIDIA Settings application. From there open from under GPU PowerMizer settings. Choose Prefer Maximum Performance from Preferred Mode.

Too bad I can't really test if that's still relevant, both Borderlands games have stopped working.

Brütal Legend that I just tried is not totally smooth, but doesn't have noticeable frame drops at least. Touching PowerMizer didn't have effect.

Dbus problems might be other thing, but for me something that beyond frame drops. More like momentary freezes. And it wasn't problem in all games, just in quite many of them.
Dysomnia 7 Apr, 2018
@Leopard: I already went through a bunch of driver versions (starting from the 36x branch) to no avail :(.

@Anza: "Prefer Maximum Performance" didn't do anything.

I recorded the issue: https://youtu.be/U3vH-IWA4lk (1080p60 for accurate depiction)- happens as soon as there's any kind of movement (even theoretical movement as evidenced in the video ಠ_ಠ). If I just stand still and watch rising smoke in the area, there aren't any visible hiccups.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.