You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay.!
Nvidia fans ramping up/down constantly ?
Guppy commented on 3 December 2018 at 8:04 pm UTC

Is there anyway to control this better cause it's getting on my nerves with the constantly spinning up/down - just pick a speed

Nvidia GTA 970 driver version 396.54

Xpander commented on 3 December 2018 at 8:15 pm UTC

nvidia-settings -a [gpu:0]/GpuFanControlState=0 -a [fan:0]/GPUTargetFanSpeed=50

you might need Coolbits first into xorg, something like:

xpander@arch ~ $ cat /etc/X11/xorg.conf.d/00-nvidia.conf Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" Option "Coolbits" "28" Option "metamodes" "DP-4: 2560x1440_144 +0+0, DP-1: null, DP-2: 2560x1440_60 +2560+0 { ForceCompositionPipeline = On }" EndSection

stan commented on 3 December 2018 at 10:02 pm UTC

I’m curious, which brand/model is it?
I haven’t had this issue with MSI Gaming X cards (GTX 660 and 1060).

Cyril commented on 3 December 2018 at 11:02 pm UTC

It works quite well on my side too (GTX 780 and driver 415.18). The fan speed is set at 40%.

Xpander commented on 4 December 2018 at 12:33 am UTC

I never had this issue with my Asus or EVGA cards (560Ti, 660Ti, 970 and 1070) but i have this issue with my Zotac AMP 1080Ti, when i force the GPU to performance mode, it will then start kicking in fans when it reaches 50°C and then it cools down and stops then and goes on and on like that. So i made a script that forces the fans to 50% when i go gaming. When im idling its set to auto though and it wont ramp up and down constantly

Guppy commented on 4 December 2018 at 7:28 am UTC

stanI’m curious, which brand/model is it?
I haven’t had this issue with MSI Gaming X cards (GTX 660 and 1060).
IIRC it's a msi - it hasn't always done this, but I'm not sure when it started doing it as I usually game with noise canceling headphones.

I'll try Xpanders solution later today

Guppy commented on 5 December 2018 at 7:48 pm UTC

didn't have the directory xorg.conf.d in /etc/X11

after a bit of digging around I found that;

sudo nvidia-xconfig --cool-bits=4

followed by a reboot gave me manual fan speed control in nvidia-settings \o/


Also it turns out that Linux Mint 19 stores the nvidia settings directly in /etc/X11/xorg.conf

Xpander commented on 5 December 2018 at 8:19 pm UTC

Guppydidn't have the directory xorg.conf.d in /etc/X11

after a bit of digging around I found that;

sudo nvidia-xconfig --cool-bits=4

followed by a reboot gave me manual fan speed control in nvidia-settings \o/


Also it turns out that Linux Mint 19 stores the nvidia settings directly in /etc/X11/xorg.conf

uhh, directly at /etc/X11/xorg.conf is not really great, because when you change your GPU from nvidia to AMD for example or change monitors when xorg.conf is filled with your current monitor setup info, then things can go south.

https://wiki.archlinux.org/index.php/Xorg#Using_xorg.conf - Archwiki link but applying to every modern distro afaik. Fedora wiki also has this.

Using .conf files
The /etc/X11/xorg.conf.d/ directory stores host-specific configuration. You are free to add configuration files there, but they must have a .conf suffix: the files are read in ASCII order, and by convention their names start with XX- (two digits and a hyphen, so that for example 10 is read before 20). These files are parsed by the X server upon startup and are treated like part of the traditional xorg.conf configuration file. Note that on conflicting configuration, the file read last will be processed. For that reason the most generic configuration files should be ordered first by name. The configuration entries in the xorg.conf file are processed at the end.

For option examples to set, see also the fedora wiki.


Well at least you got it working now

devnull commented on 6 December 2018 at 9:05 am UTC

Assuming there aren't actual thermal reasons for the fans spinning, I've had this happen with a GTX 980TI.. Had to power completely off to reset the card.

You can check / monitor with nvidia-smi rather then going into nvidia-settings.

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
None currently, submit yours here!
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts