Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Flattr, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
No Man's Sky 2.52 No Multiplayer on Proton 5.0-9 running Pop!_OS 20.04
Page: 1/3»
  Go to:
ALazyDope 20 Jun

The steam version of No Man's Sky does not seem to have working multiplayer (No players on Anomaly, can't join to other players, regardless of platform), and it seems that people on ProtonDB say that multiplayer works fine, so I'm curious if there is something wrong with my configuration, which I haven't made any modifications to yet. Link to my hardware configuration here if that will help any, and I'd be happy to give details of any other configuration files if requested. I'm still a bit new to Linux, and I just don't really know where to start yet.

CatKiller 20 Jun

I turned multiplayer off on mine but it was working fine before I did that, which would have been probably just before the Living Ship update. I didn't need to do anything to make it work, and it's an in-game setting to turn it off as I recall.

Just turned it on again in-game and it's still working fine.

Last edited by CatKiller on 20 June 2020 at 9:20 pm UTC

ALazyDope 20 Jun

No, unfortunately it tells me there is no connection to matchmaking services, but it's good to know it might be solvable

ALazyDope 20 Jun

I've only started playing on Linux in the most recent update, and I've also just tried reinstalling the game. This didn't solve the issue however

CatKiller 21 Jun

Looking around a bit, it seems that a lot of Windows users are having the same problem. I've no idea where the issue might lie, since it's always just worked for me.

ALazyDope 21 Jun

Yeah, I noticed that too, but there were some that reported reinstalling fixed the issue, and seeing as that didn't work for me, I was hoping there was a solution that was more applicable, thanks for the help regardless.

CatKiller 21 Jun

One possible line of inquiry is IPv6. My ISP's policy with IPv6 is "we ain't got none," so I know that I'm definitely using IPv4, and I know that IPv6 connectivity has tripped up other devs in the past, so it's a possibility.

Other than that I can't think of anything useful.

ALazyDope 21 Jun

I thought I would note that I use a wired connection, that 1Pv6 and v4 were both enabled, but outright disabling v6 didn't change anything, and I also tried the builds of proton by GE and TKG, still with no success, thanks for your help and if we're stuck at an impasse then I have a few posts else were that might come up with something, and if there are any logs I can provide or generate that might also help then I'd be happy to provide them

ALazyDope 22 Jun

Just as a note, there was no change on Wifi vs Wired, or with or without a VPN

Patola 22 Jun

Are you using docker on your Linux? There is an issue with docker virtual interfaces that might prevent some games from working in multiplayer.

ALazyDope 22 Jun

Nope, not using Docker, and No Man's Sky is the only game multiplayer doesn't work on

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.


Or login with...