Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Flattr, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
Risen enable Anti-Aliasing
Spirimint 10 Aug

Hey Guys,

finally i wanna play some Risen 1. The game looks good and works out of the box in wine. But i can't figure out how to enable Anti-Aliasing. I know the game does not have it included, but i read you can force your driver to do Anti-Aliasing. But my Nvidia Settings won't work. Can anybody help?

Thanks in advance :)

Last edited by Spirimint on 10 August 2020 at 9:48 pm UTC

Jared 10 Aug

That is going to be difficult consideriny thay anti-aliasing was never made available natively to Risen 1. This may or may not work but there is no harm in trying. First go into the terminal and check what antialiasing modes your graphics card supports by entering this command:
 
nvidia-settings --query=fsaa --verbose

You should get a list of various outputs such as:
 
Valid 'FSAA' Values
      value - description
        0   -   Off
        1   -   2x (2xMS)
        5   -   4x (4xMS)
        7   -   8x (4xMS, 4xCS)
        8   -   16x (4xMS, 12xCS)
        9   -   8x (4xSS, 2xMS)
       10   -   8x (8xMS)
       11   -   16x (4xSS, 4xMS)
       12   -   16x (8xMS, 8xCS)
       14   -   32x (8xMS, 24xCS)

Once that is done, go to nvidia-settings and try to find Application Profiles. Next go onto Profiles and create a new one. Give it any name and select GLFSAAMode from the ist provided from the drop down menu. On the section (input) titled Value choose a number for the mode of FSAA you wish to use such as if you want 8 for 16x FSAA). After doing so, this would convert the number as a hexadecimal, which you should save.

On the tab labelled as Rules, create a new rule. For Process Name use Pattern and for the String choose Risen.exe. Then onto Profile Name ahgain, choose the profile to which you have saved previously (the one with the hexadecimals).

Afterwards, go to the checkbox in Application Profiles and tick Enable application profiles then proceed to save the changes.
It may or may not work but there isn't any harm in trying it out.

Spirimint 11 Aug

So far it did not work. But i could not choose Pattern for Process Name.

I made some pics to see if everything correct.

link

Last edited by Spirimint on 11 August 2020 at 7:34 am UTC

Patola 11 Aug

Quoting: SpirimintSo far it did not work. But i could not choose Pattern for Process Name.

I made some pics to see if everything correct.

link
You might also try to change properties/launch parameters and use __GL_FSAA_MODE, e.g.  
__GL_FSAA_MODE=0x8 %command%

Spirimint 11 Aug

Quoting: Patola
Quoting: SpirimintSo far it did not work. But i could not choose Pattern for Process Name.

I made some pics to see if everything correct.

link
You might also try to change properties/launch parameters and use __GL_FSAA_MODE, e.g.  
__GL_FSAA_MODE=0x8 %command%

just type __GL_FSAA_MODE=0x8 %command% in console or could you explain it more?

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.