Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone. Just good, fresh content! Alternatively, you can donate through PayPal. You can also buy games using our partner links for GOG and Humble Store.
Unity error?
harshbarj Sep 7, 2020
Hey all. decided to finally build a game that I have wanted to for nearly a decade. So far when compiled it works fine under windows, but if I compile it for linux x86_64 I get an error when I try to run it in linux.

This is the error I get with Mint 20.

 
:~/survival build linux$ ./ZedSurvival.x86_64
Set current directory to /home/harshbarj/survival build linux
Found path: /home/harshbarj/survival build linux/ZedSurvival.x86_64
no boot config - using default values 
(Filename:  Line: 474)


I read that some say this means the data directory was not present, but it is in my case. All 1gb of it, just as in windows.

Really want to keep an eye out for Linux specific error while building this game. So I'd like to build it with every major change and playtest it.

Any clue as to that this error could mean?
damarrin Sep 7, 2020
Wrong case for data directory name? And possibly other filenames, too...
harshbarj Sep 7, 2020
Quoting: damarrinWrong case for data directory name? And possibly other filenames, too...

Not sure. Just tried building it in linux and it worked fine. So when I want to test i'll have to do the Linux builds in Linux. Not the end of the world really.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register


Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.