Check out our Monthly Survey Page to see what our users are running.
Weird issue with launching Total War: SHOGUN 2 (Steam ver.)

Having a weird issue with Total War: Shogun 2, where it apparently won't run if executed directly trough the Steam client.

Though; For some weird reason or another, I can run it just fine by manually executing the Shogun2.sh launch script (located at ~/.local/share/Steam/steamapps/common/Total War SHOGUN 2/Shogun2.sh) in a terminal, and letting that launch Steam in addition to the game...

$ cd "$HOME/.local/share/Steam/steamapps/common/Total War SHOGUN 2/"
$ ./Shogun2.sh


Which will launch the Steam client and then autostart the game/app itself, just fine..

Though if i simply click "Play" on the game in the Steam client, the green "Running" status will only show for a split second or two, and then nothing happens..


I would assume that Steam would be using the Shogun2.sh script to launch the game upon clicking "Play" ..So why there seems to be a difference, i've no idea ATM.. And terminal output does not provide any useful info regarding what's the problem, as far as i can tell..


Anyone here experienced something similar, or have any tips on how to troubleshoot it further, or preferably how to resolve it?.. It's quite annoying having to give a game 'special treatments' to run it.. ...


Note: I've also got Total War: Warhammer (and Deus Ex: Mankind Divided), which are both utilizing the same engine etc. etc. , but which both does launch perfectly without issues whatsoever..

  • hastebin listings of Feral's "Generic Feral Launcher script" source: Shogun2.sh script


Last edited by Duck Hunt-Pr0 on 19 September 2020 at 6:36 pm UTC

Arno 6 Oct

Hey there

I'm having the same issue. The game *should* run natively, but besides the quick green flash that says I'm running the game, nothing happens.

I also tried your solution, but that also does nothing unfortunately.
This is what I get:

WARNING: Total War SHOGUN 2 not launched within the steam runtime
         This is likely incorrect and is not officially supported
         Launching steam in 3 seconds with steam://rungameid/34330
Manjaro steam native configuration found!
Running Steam on manjarolinux 20.1.1 64-bit
STEAM_RUNTIME is disabled by the user
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/arno/.local/share/Steam/ubuntu12_32/steam steam://rungameid/34330


I tried different compatibility tools too, to no avail.
Any helpful pointers would be welcome!

whizse 6 Oct
  • Supporter

Any error messages if you launch steam from a terminal and then launch the game normally?

(Steam outputs a lot of text during start, so it's most likely the messages printed after you hit the play button that's of interest.)

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts