Check out our Monthly Survey Page to see what our users are running.
STEAM_RUNTIME is disabled by the user ?
Page: 1/3»
  Go to:
Tchey 20 Oct, 2020

Hello,

I just restarted my computer after an automatic update, like mostly weekly, but now i cannot launch Steam anymore.
I used to open a Terminal and write Steam, now i see this :

 
steam 
Manjaro steam native configuration found!
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is disabled by the user
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam


 
[tchey@ordimanj ~]$ echo $STEAM_RUNTIME

[tchey@ordimanj ~]$ STEAM_RUNTIME=1 steam
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!
Steam client's requirements are satisfied
/home/tchey/.local/share/Steam/ubuntu12_32/steam

[tchey@ordimanj ~]$ Steam
bash: Steam: command not found

[tchey@ordimanj ~]$ steam
Manjaro steam native configuration found!
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is disabled by the user
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam

[tchey@ordimanj ~]$ echo $STEAM_RUNTIME
1

[tchey@ordimanj ~]$ steam
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!

Steam client's requirements are satisfied
/home/tchey/.local/share/Steam/ubuntu12_32/steam


Save me please.

Linux Manjaro (Arch) 64bits Xfce
Intel Core i5 4590 (4 x 3,3 GHz)
GeForce GTX 1060 @ 6 Go
Nvidia Drivers
16 Go DIMM DDR3 PC12800
SSD Crucial 480Go
BENQ GL2460 16/9 24" 1920x1080

Last edited by Tchey on 20 October 2020 at 1:47 pm UTC

This topic has an answer marked - jump to answer.
The_Aquabat 20 Oct, 2020

I think it's a problem with the pins, try

deleting this
~/.steam/ubuntu12_32/steam-runtime/pinned_libs_64
~/.steam/ubuntu12_32/steam-runtime/pinned_libs_32
~/.steam/ubuntu12_32/steam-runtime.old/pinned_libs_64
~/.steam/ubuntu12_32/steam-runtime.old/pinned_libs_32

and

~/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs64
~/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs32
~/.local/share/Steam/ubuntu12_32/steam-runtime.old/pinned_libs_64
~/.local/share/Steam/ubuntu12_32/steam-runtime.old/pinned_libs_32

then
steam --reset

this will reset all your steam settings, force rebuild the pins and you 'll have to point the settings again to the correct directories where the games are installed.

after that launch steam normally.

Last edited by The_Aquabat on 20 October 2020 at 2:30 pm UTC

Tchey 20 Oct, 2020

Hm, catfish only found
.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64

but not
~/.steam/ubuntu12_32/steam-runtime/pinned_libs_64

https://www.zupimages.net/up/20/43/k7nv.jpg

Then

 
[tchey@ordimanj ~]$ steam --reset
Manjaro steam native configuration found!
Installing bootstrap /home/tchey/.local/share/Steam/bootstrap.tar.xz
Reset complete!

[tchey@ordimanj ~]$ steam
Manjaro steam native configuration found!
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is disabled by the user
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam


I checked and games files are installed here :
/home/tchey/.steam/steam/steamapps/common/

Last edited by Tchey on 20 October 2020 at 3:14 pm UTC

serge 20 Oct, 2020

Hello,

I don't know what they do with manjaro, but with arch when you install steam you can launch it with steam (runtime) and steam-native (system libs).

There is "Manjaro steam native configuration found!" when you enter steam, so it seems to be configured for the system libs, on arch i use the package "steam-native-runtime" to install all the libs

Tchey 20 Oct, 2020

It seems i have both -manjaro and -native installed

I tried to reboot, check update, but same.

https://zupimages.net/up/20/43/jeag.jpg

Last edited by Tchey on 20 October 2020 at 3:32 pm UTC

serge 20 Oct, 2020

Try to remove steam-native

Tchey 20 Oct, 2020

Message "build pin potentially out of date", then

 
[tchey@ordimanj ~]$ steam
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam
[tchey@ordimanj ~]$ 


Then i rebooted my PC, and :

 
[tchey@ordimanj ~]$ steam
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam
[2020-10-20 17:51:38] Startup - updater built Jul 28 2020 22:37:33
[2020-10-20 17:51:38] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(1602795778)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
^C
[tchey@ordimanj ~]$ 


It’s stuck, i did Ctrl+C to stop the terminal after a few minutes.

Last edited by Tchey on 20 October 2020 at 3:56 pm UTC

Xpander 20 Oct, 2020

there is no ~/.steam/ubuntu12_32...

there is ~/.steam/steam/ubuntu12_32/steam-runtime/pinned_libs_32

at least on Arch.

Maybe you have some weird permission issues, so it can't access the correct paths?

edit: the error after rebooting your machine seems to be related to 32 bit driver missing? check your drivers

Last edited by Xpander on 20 October 2020 at 5:35 pm UTC

The_Aquabat 20 Oct, 2020

try this run steam like this through the command line

STEAM_RUNTIME_PREFER_HOST_LIBRARIES=1  steam

if there is no error window message then try

STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0  steam


report if there's an error message window what is saying.

Last edited by The_Aquabat on 20 October 2020 at 6:17 pm UTC

Tchey 20 Oct, 2020

No luck so far :

 
[tchey@ordimanj ~]$ STEAM_RUNTIME_PREFER_HOST_LIBRARIES=1  steam

Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam

[tchey@ordimanj ~]$ STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0  steam

Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 is deprecated, and no longer has an effect.
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/tchey/.local/share/Steam/ubuntu12_32/steam

The_Aquabat 20 Oct, 2020

try completely removing steam-runtime dir from the same folder in ~/.steam/steam/ubuntu12_32 and in ~/.local/share/Steam/ubuntu12_32

and launching again.

then the last resort is nuking the steam directory.. (I hope you have your games installed in other directory)
rm -dfr ~/.steam
rm -dfr ~/.Steam
rm -dfr ~/.local/share/Steam


steam --reset

and try running it again.

Last edited by The_Aquabat on 20 October 2020 at 7:06 pm UTC

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts