Check out our Monthly Survey Page to see what our users are running.
Fans running very high after running Starcraft 2 with Wine over Lutris
Jendker 24 Oct

I am running Starcraft 2 on Ubuntu 20.04 over Lutris. I selected Lutris because it was often complemented as an easy way to set up Linux for gaming. I have installed the game through this link: https://lutris.net/games/starcraft-ii/ and selected "WINED3D+ESYNC version" as it has very good rating.

The game runs very well, the only problem is that after finishing the game the fans keep running really high (sometimes slower, sometimes faster, but always way to fast even if the CPU is completely on idle). I was trying to kill the Wine processes with `killall Agent.exe Battle.net.exe wineserver`, but it does not help. I have to restart the PC so that the fans go back to normal and it happens like this every time.

I have tried reinstalling the game and installing some software to control the fans called `fancontrol`, but it does not work as my motherboard seems not to support it. I only get information, that there are no fans detected.

Could you please give me a hint what should I look for to fix this? Currently I need to keep rebooting to Windows, because, well I need to do the reboot after playing anyway...

CatKiller 24 Oct

If you have got a process left over that hasn't been terminated when the game exits, htop would be a good way to see that. You can kill processes from within htop, or just see the PID to kill it manually.

whizse 24 Oct
  • Supporter

killall takes a signal argument, so sending SIGKILL "killall -9 Agent.exe Battle.net.exe wineserver" should get rid of any unruly processes.

Is any process really spinning the CPU though? You wrote that the fans are still on even when the CPU is completely idle?

Xpander 24 Oct

to kill all wine related stuff, use this script:

pids=$(
    ls -l /proc/*/exe 2>/dev/null |
    grep -E 'wine(64)?-preloader|wineserver|winedevice.exe' |
    perl -pe 's;^.*/proc/(\d+)/exe.*$;$1;g;'
)

if ((${#pids})); then
    echo $pids
    kill $pids
    
    sleep 1
    
    pids=$(
        ls -l /proc/*/exe 2>/dev/null |
        grep -E 'wine(64)?-preloader|wineserver|winedevice.exe' |
        perl -pe 's;^.*/proc/(\d+)/exe.*$;$1;g;'
    )
    
    if ((${#pids})); then
        kill -9 $pids
    fi
fi

Jendker 25 Oct

Thank you all for the answers!

Quoting: whizseIs any process really spinning the CPU though? You wrote that the fans are still on even when the CPU is completely idle?

Yes, exactly. There is no CPU usage and fans are still spinning. So seems that some settings are being changed and by killing all the wine processes I wanted to reset it.

Thank you @Xpander, I will try it out after the weekend as soon as I have the access to laptop again.

whizse 25 Oct
  • Supporter

Weird. There's nothing in Wine or the game that can actually change fan speeds, but maybe one process is keeping the GPU busy?

I'm also curious about Lutris, I don't use it myself. Possibly it could be changing the CPU governor to a performance mode when the game is running and fails to set it back if the game doesn't exit cleanly?

Jendker 25 Oct

Thanks for the hint @whizse, I think I am getting closer to the answer. I'll check the both and let you know what I found.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams