You can sign up to get a daily email of our articles, see the Mailing List page!
Proton-5.9-GE-8-ST no longer starts a game.
D1Ck3n 9 Nov, 2020
Hello everyone,

I wanted to play Far Cry 5 and read on ProtonDB that it should work fine with the Custom Proton version of GloriousEggrole, but unfortunately no game from Steam starts with this version anymore!

I installed Wine, Winetricks and the latest Nvidia driver.

what could be the reason for that? With the latest Proton version of Valve everything works (except FC5)

My System:
 
██████████████████  ████████   merlin@MT-PC 
██████████████████  ████████   ------------ 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: MS-7C02 1.0 
████████            ████████   Kernel: 5.9.3-1-MANJARO 
████████  ████████  ████████   Uptime: 1 day, 14 hours, 4 mins 
████████  ████████  ████████   Packages: 2042 (pacman), 4 (snap) 
████████  ████████  ████████   Shell: zsh 5.8 
████████  ████████  ████████   Resolution: 1920x1080, 1920x1080 
████████  ████████  ████████   DE: Cinnamon 
████████  ████████  ████████   WM: Mutter (Muffin) 
████████  ████████  ████████   WM Theme: Mint-Y-Dark-Teal (Mint-Y-Dark) 
████████  ████████  ████████   Theme: Mint-Y-Dark-Teal [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Dark-Maia [GTK2/3] 
                               Terminal: gnome-terminal 
                               CPU: AMD Ryzen 5 2600X (12) @ 3.999GHz 
                               GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590 
                               GPU: NVIDIA GeForce RTX 2080 Rev. A 
                               Memory: 12535MiB / 32060MiB 
Julius 9 Nov, 2020
Works fine here also on Manjaro. I know that isn't very helpful, but you probably messed something up while installing it.
Schattenspiegel 9 Nov, 2020
Seeing your uptime: if you freshly installed the drivers or a kernel, try a system restart, it might solve the problem. Otherwise I agree. Your best bet might be double checking and redoing your proton-GE installation.
robvv 9 Nov, 2020
For Far Cry 5, one person on ProtonDB is recommending Proton 5.13-1.
D1Ck3n 9 Nov, 2020
Quoting: robvvFor Far Cry 5, one person on ProtonDB is recommending Proton 5.13-1.

okay, i tested it and it worked! But i get this message shown the whole time:
Screenshot
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts