Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone with no article paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
No Sound in some games
Slackdog 20 Nov, 2020
Weird one this - after a recent update some games - native ones only it seems - have no sound. Ones affected so far are;

Horizon Chase Turbo
Dusk
BallisticNG
Broforce

Others HL2, proton games are unaffected. Systems sounds, movies and music etc play as normal :S

Sounds settings looks ok as does ALSA - Am using Ubuntu 20.10 standard - any ideas?
whizse 20 Nov, 2020
  • Supporter
Anything in the terminal when launching those titles?

Anything in common between the ones that doesn't work? Running in Steam or not? 32bit or 64bit?

Anything missing after the update? dist-upgrade removed something perhaps?
Slackdog 20 Nov, 2020
Steam all of them - should have said, sorry! The games run just fine but silently. I wonder if it's the game engine..

As an added irony Halo 3 on proton now has sound - might reinstall pulse...
Slackdog 21 Nov, 2020
Horizon chase turbo all good using proton. Somewhere to start :)
whizse 21 Nov, 2020
  • Supporter
Might give the Steam Linux Runtime a try? It should be in the settings where you choose Proton version.

Otherwise, check logs from the games and/or running Steam in a terminal and checking for relevant error messages.

HTH,
Slackdog 21 Nov, 2020
Rolled back to an older kernel and get sound. Guess I get to file a bug report! Messed up my GPU driver but sounds there are.

Help much appreciated! :)
Slackdog 21 Nov, 2020
And then a fsck (nothing found) and a reboot fixed it. Weird.
whizse 21 Nov, 2020
  • Supporter
Odd that only some games were affected, but all's well that ends well!
Slackdog 21 Nov, 2020
Oh it's a whole load of weird but that's for tomorrow!
Slackdog 27 Nov, 2020
Ooook so the sounds works but it's using my speakers and not my headphones! Reinstalled as Linux version - sound set to headphones. This is really, really odd!
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts