Check out our Monthly Survey Page to see what our users are running.
Is it possible to assign a "primary monitor" in a Plasma Wayland session? Games always show up on left monitor...
Page: 1/2»
  Go to:
ridge 2 Oct
So I'll start this out with simply, I know Nvidia + Wayland + KDE is far from perfect, but at this point it's SO CLOSE to becoming my daily driver, and I wonder if this final issue can be resolved to allow that to actually happen.

I use an Nvidia GTX 1060 with three monitors, Manjaro testing branch, KDE Plasma 5.23 Beta. When I log into a Wayland session and try to run a fullscreen game, it shows up on my left monitor instead of the middle, which is assigned as my primary in X11 sessions.

But MAN, is Wayland SILKY smooth! It's such a shame to always have to clench my teeth and go back to X11 when I want to play something. Native, Wine, Proton, doesn't matter, anything running in fullscreen shows up on the left monitor. I've tried making a window rule to force games to position 1920,0 (since my monitors are all 1080p), what's weird is Plasma just crashes, goes completely black when I click save in Plasma settings. Sure they get saved but the rule doesn't work, sadly.

Is there a way?! Can I have my cake and eat it too now, by way of making fullscreen apps appear on the center monitor, or is it too early? Thanks in advance, everyone! ^^

Last edited by ridge on 2 October 2021 at 6:40 pm UTC
This topic has an answer marked - jump to answer.
Eike 3 Oct
KDE's "special settings for window" also have a force monitor setting - on my old KDE with X.
In my old KDE it in system settings, window behaviour, window rules.
(You could try something like "window class" "contains" "steam_app" to match all games.)
ridge 3 Oct
Quoting: EikeKDE's "special settings for window" also have a force monitor setting - on my old KDE with X.
In my old KDE it in system settings, window behaviour, window rules.
(You could try something like "window class" "contains" "steam_app" to match all games.)

You'd think this would be the temporary catch-all solution to solve aforementioned woes, couldn't get force position on monitor to work on my machine tho. Thanks for posting this however, others should definitely try this just in case!

By the way, I see you have an Nvidia card. You say old KDE with X, are you using Wayland now or have used it? Does saving changes to Plasma settings make the entire DE crash for you as well?

Last edited by ridge on 4 October 2021 at 6:17 pm UTC
Eike 3 Oct
Quoting: ridge
Quoting: EikeKDE's "special settings for window" also have a force monitor setting - on my old KDE with X.
In my old KDE it in system settings, window behaviour, window rules.
(You could try something like "window class" "contains" "steam_app" to match all games.)

You'd think this would be the temporary catch-all solution to solve aforementioned woes, couldn't get force position on monitor to work on my machine tho. Thanks for posting this tho, other should definitely try this just in case!

By the way, I see you have an Nvidia card. You say old KDE with X, are you using Wayland now or have used it? Does saving changes to Plasma settings make the entire DE crash for you as well?

I'm very conservative with respect to software at the moment: Debian buster, X server. Never tried Wayland. (Too little time for experiments nowadays...)
ridge 3 Oct
Quoting: EikeI'm very conservative with respect to software at the moment: Debian buster, X server. Never tried Wayland. (Too little time for experiments nowadays...)

Completely understandable! Thanks for getting back to me.
Sojiro84 3 Oct
For now, you need to set the monitor through the terminal.

I made a script so that it always pick's the monitor with the right resolution, which for me is 2560x1440. My other monitor is vertical so that one never gets picked now. I have another script that I sometimes run when I want to game in the TV that has a 4K resolution.

xrandr --output "$(xrandr --query | grep 'connected.*2560x1440' | grep -o 'XWAYLAND[0-9]*')" --primary

Another way is to check what for number your monitor is. You do "xrandr" first in the terminal and find your monitor, then you can do:

xrandr --output XWAYLAND1 --primary

Where XWAYLAND1 is your monitor.

But yeah, there definitely needs to be a solution implemented so that we don't have to keep doing this.
ridge 4 Oct
Quoting: Sojiro84For now, you need to set the monitor through the terminal.

I made a script so that it always pick's the monitor with the right resolution, which for me is 2560x1440. My other monitor is vertical so that one never gets picked now. I have another script that I sometimes run when I want to game in the TV that has a 4K resolution.

xrandr --output "$(xrandr --query | grep 'connected.*2560x1440' | grep -o 'XWAYLAND[0-9]*')" --primary

Another way is to check what for number your monitor is. You do "xrandr" first in the terminal and find your monitor, then you can do:

xrandr --output XWAYLAND1 --primary

Where XWAYLAND1 is your monitor.

But yeah, there definitely needs to be a solution implemented so that we don't have to keep doing this.

YOU ARE A SAINT! Thank you so much!
That script is great, for me tho just setting my monitor as primary with xrandr was enough, fullscreen apps now start on the correct monitor and gameplay is SO smooth.

I can't thank you enough
pete910 4 Oct
I just set the primary monitor in system settings.


Or is this a Nvidia thing ?
ridge 4 Oct
Quoting: pete910I just set the primary monitor in system settings.


Or is this a Nvidia thing ?

Not sure if it's Nvidia specific, which version of KDE software are you on? When I'm in a Wayland session, I can't specify primary screen in settings. I can on X11 however.
pete910 4 Oct
Quoting: ridge
Quoting: pete910I just set the primary monitor in system settings.


Or is this a Nvidia thing ?

Not sure if it's Nvidia specific, which version of KDE software are you on? When I'm in a Wayland session, I can't specify primary screen in settings. I can on X11 however.

5.22 , it's always worked both on X11 and wayland. Have to admit though I've only been using wayland for the last few months.
ridge 5 Oct
Quoting: pete9105.22 , it's always worked both on X11 and wayland. Have to admit though I've only been using wayland for the last few months.

Hmm, maybe it is then, I'm on the same version. But hey, maybe that means it's close to being added :)
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts