Join us on our own very special Reddit on /r/Linuxers.
Slow Download Speeds on the Deck
Cookies 18 Aug
I'm getting low speeds when downloading games on the deck and I cant figure out why.
Downloading to internal SSD using a wired connection is around 10MB, same with SD card, also 10MB.
Wifi is also similar speeds <10MB just more random than wired.
Firefox speed test in desktop mode shows 300Mbit so I should be able to get at least 30MB. Internet connection is 1gig but dongle must be slowing it down to 300.
I tried changing DNS, Region, disabling wifi power savings and nothing helped.
Benchmarking the SSD showed 2.4GB reads and SD card 90MB so hardware seems fine.
On my PC I get the full speed I expect from steam and both are connected to same network switch.
I saw people getting 70MB on the deck online so its weird than I only get 10-ish.

Anyone has any ideas?
damarrin 18 Aug
You have the download speed limit set in Steam?
Cookies 18 Aug
Nope, no download limits set.
I actually tried 0 (default) and also setting it to like 1000000 since someone online mentioned setting it to something else than 0 worked for them but it was no change for me.

I also found a post online on the steam forums that looked like the exact issue as me but the reason for them was Pi-hole on the network which I don't have.
peta77 18 Aug
Is it a general issue? I noticed that for me some games have poor download rates while with others i get full speed. For initial download as well as for updates. The more popular the game, i.e. the more (active) users it has, the better the download rates. So maybe it's just a server issue where you are redirected to some slow server for rarely used download material....
Cookies 18 Aug
Yea, it seems to be a general issue, so far for all the games I have tried to install. I tried around 7 games.

I did mostly try less known/older games before as you mentioned but I tried Elden Ring just now which should still be popular and I'm getting around 4.5 MB on wired on Deck.
Cookies 23 Aug
Solved it, turned out my USB C ethernet dongle was just crappy or had some weird compatibility issue.
Ordered another just to test and it worked. Now getting speeds up to 60MBs from steam.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.