You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
Steam controller not working just on TR and TW2
donbastiano commented on 9 December 2017 at 10:10 am UTC

I have a strange problem with the steam controller, generally it is working fine but not with The Witcher 2 where doesn't appear and on Tomb Raider: with this game it has a strange behavior, while I hold L2 and move the controller, it moves the menu and it is the only thing that I can do On past it has worked fine on TR.
It is an almost clean installation of Ubuntu 17.10 (but on Unity), I copied some folder from the old pc i.e. the steamapps. I installed steam with apt and also the steam-devices pkg that brought the /lib/udev/rules.d/99-steam-controller-perms.rules file, without this pkg steam doesn't show any controller. I'm on the stable release of steam.
I tried with big picture and also loading a controller configuration from the community but nothing has changed.

Any suggestion?

skyrrd commented on 11 December 2017 at 8:13 am UTC

The steamcontroller part of your udev-rule should have s group listed (usually its "input" or something simmilar)
Make sure your user is part of that group.
E.g. gpasswd -a user input

If it's still not working with witcher 2 i suggest to check needed libs. (Gog-site has a list of needed packages)

donbastiano commented on 11 December 2017 at 10:03 pm UTC

Thank you, I don't have any group in the rule, it is the default file from the steam-devices package (link to the content). I had the same file previously, I think your are suggesting what liam said a year ago (link), I thought it wasn't necessary anymore but I'm going to try it, changing:
KERNEL=="uinput", SUBSYSTEM=="misc", TAG+="uaccess"
to
KERNEL=="uinput", MODE="0660", GROUP="pgriffais", OPTIONS+="static_node=uinput"
with the right group

donbastiano commented on 24 January 2018 at 8:43 pm UTC

Thank you, I really enjoyed TR, played with the steam controller. A little strange that the default configuration is not working... but easy fix

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
See more!
Popular this week
View by Category
Contact
Latest Forum Posts
Facebook