Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through Paypal, Flattr and Liberapay!
  Go to:
[SOLVED] Connecting Wii Remote Plus on Ubuntu for Dolphin
Linuxwarper commented on 26 March 2018 at 8:12 pm UTC

SOLUTION OR WHAT IS BELIEVED TO BE: The bluetooth dongle, Hama 49218, does not work with Dolphin for bluetooth. Nor emulator or passthrough.
Initially I did not have access to bluetooth passthrough because I was using stable version of Dolphin, when you needed to be on development branch.


ORIGINAL POST
After several attempts to connect Wii Remote Plus to Dolphin I have come to ask for help:

- Checkbox success (for dongle)
- Successfully sent image and video from pc to smartphone with Bluetooth. Could not send image or video from phone to pc though.
- Sucessfully connected Beats headset with bluetooth dongle

- Followed Dolphin site, stated no additional things needed for Linux for controller to work. Set controller settings to real wiimote with continuous scanning

- Controller worked fine using a Windows laptop. There was a issue with movement not working right during Wii Resort games, where the pointer disappeared or did not move properly with motion, making it difficult to point and press A to start a match/game. Past that point the motion worked well enough to play the games with it. Worked just fine with Super Mario game even the motion features in the game. Not to say it didn't in Wii Resort but during menus and similar the motion did not work well or at all.

- Pressed both 1+2 and Sync when trying to connect/pair wiimote to bluetooth manager of Ubuntu and during and after game start when in Dolphin.
- As I had both bluetooth 2.0 and 3.0 on pc, I tried different ports to see. Successfully found the wiimote under "joypad" with 2.0 but not with 3.0 ports.
- Selected wiimote in the list of discovered devices, plugged into a 2.0 usb port, but the "next" button is greyed out not allowing to progress the connection/pairing.

Any suggestions on what else I can test to troubleshoot the issue? Thanks

Ubuntu 16.04 LTS


EDIT:
Controller is found but is not paired. I believe the reason it is not picked up in Dolphin is because it's not paired up with PC. On Windows I had to pair up the control for it to work in Dolphin.
https://imgur.com/a/sXDoy

whizse commented on 26 March 2018 at 8:50 pm UTC

Debian user here.

I have an original Wiimote (third party sensor bar) working fine with Dolphin.

I have never set it up using the systems Bluetooth settings. Only directly through Dolphin. (Start Dolphin, set it to scan, set controller to sync)

The only problem I've had is having to re-sync the controller every time I restart Dolphin.

Linuxwarper commented on 26 March 2018 at 9:24 pm UTC

whizseDebian user here.

I have an original Wiimote (third party sensor bar) working fine with Dolphin.

I have never set it up using the systems Bluetooth settings. Only directly through Dolphin. (Start Dolphin, set it to scan, set controller to sync)

The only problem I've had is having to re-sync the controller every time I restart Dolphin.
I've tried that, does not work. Thanks for input though

EDIT: It's a wii remote plus not original. Dolphin help says it should work fine without any additional software on Linux.

whizse commented on 27 March 2018 at 4:44 pm UTC

More guesses/suggestions:

Dolphin should handle the pairing itself, have you tried removing it from the list of previously attached devices in Ubuntu before launching Dolphin?

Is there a difference if you press the sync button instead of 1 and 2 (I'm guessing the Plus controller still got one?)

If that fails, it might work better with direct pass-through?
https://wiki.dolphin-emu.org/index.php?title=Bluetooth_Passthrough

Might be wonky Linux drivers for your particular Bluetooth controller.


Scratch what I wrote previously. I'm actually using passthrough myself, forgot I had it set up. But it does seem to be working fine here, so it's probably worth a shot for you too:
https://wiki.dolphin-emu.org/index.php?title=Bluetooth_Passthrough

Linuxwarper commented on 27 March 2018 at 11:23 pm UTC

whizseMore guesses/suggestions:

Dolphin should handle the pairing itself, have you tried removing it from the list of previously attached devices in Ubuntu before launching Dolphin?

Is there a difference if you press the sync button instead of 1 and 2 (I'm guessing the Plus controller still got one?)

If that fails, it might work better with direct pass-through?
https://wiki.dolphin-emu.org/index.php?title=Bluetooth_Passthrough

Might be wonky Linux drivers for your particular Bluetooth controller.


Scratch what I wrote previously. I'm actually using passthrough myself, forgot I had it set up. But it does seem to be working fine here, so it's probably worth a shot for you too:
https://wiki.dolphin-emu.org/index.php?title=Bluetooth_Passthrough
Do you have a Wii Remote Plus as well or is it a standard Wiimote? (Will give passthrough a go now)

EDIT: I need to install a udev rule. Have no idea what that is and what I do with the line of code for the rule that Dolphin has provided.

SUBSYSTEM=="usb", ATTRS{idVendor}=="YOURVID", ATTRS{idProduct}=="YOURPID", TAG+="uaccess"

tuubi commented on 28 March 2018 at 8:46 am UTC

https://github.com/dolphin-emu/dolphin/blob/master/Data/51-usb-device.rules

Try copying that file into /etc/udev/rules.d/ and then running sudo udevadm control --reload-rules

Might be that the vendor and product id need to be adjusted if you've got third party hardware. I don't have the hardware so I can't test any of this.

whizse commented on 28 March 2018 at 10:00 am UTC

Find the VID and PID with lsusb

Put the rule in /etc/udev/rules.d/52-dolphin.rules

Reload the udev rules sudo udevadm control --reload-rules

Unplug/plug in the bluetooth adapter.

(Might be easier to just reboot after adding the rule)

whizse commented on 28 March 2018 at 10:06 am UTC

tuubihttps://github.com/dolphin-emu/dolphin/blob/master/Data/51-usb-device.rules

Try copying that file into /etc/udev/rules.d/ and then running sudo udevadm control --reload-rules

Might be that the vendor and product id need to be adjusted if you've got third party hardware. I don't have the hardware so I can't test any of this.
So, that file should already be shipped with Dolphin (at least in the Debian package).

I think that file is for the GC adapter and Dolphinbar. Bluetooth passthrough gives Dolphin exclusive access to the Bluetooth dongle.

Linuxwarper commented on 1 April 2018 at 12:38 am UTC

whizseFind the VID and PID with lsusb

Put the rule in /etc/udev/rules.d/52-dolphin.rules

Reload the udev rules sudo udevadm control --reload-rules

Unplug/plug in the bluetooth adapter.

(Might be easier to just reboot after adding the rule)
I copied the rule and added VID and PID values where rule says I should add it. I removed the YOURVID (in "YOURVID") and pasted what I believe was VID based on output from lsusb (X:Y output).

Restarted computer, launched Dolphin and looked for Bluetooth passthrough option per Dolphin instructions. Did not find that. Tried syncing controller after starting game, did not work. Ran the command to reload udev rules, no effect after that either.

NOTE: I did additional testing, bluetooth dongle connected successfully to a bluetooth beats headset. So the bluetooth functionality works even though it may not be 100% optimal (volume could be higher?).

EDIT:
SUBSYSTEM=="usb", ATTRS{idVendor}=="YOURVID", ATTRS{idProduct}=="YOURPID", TAG+="uaccess"
^ Am I to remove the text YOURVID and YOURPID and replace them with value from lsusb? Nothing further needed to change before saving the text as a .rules file?

whizse commented on 1 April 2018 at 1:15 pm UTC

Sounds like you did everything correctly. Not sure what else to try. You'll probably have to ask on the dolphin mailing lists/forums.

Linuxwarper commented on 1 April 2018 at 9:39 pm UTC

Thanks to everyone who pitched in to help me. The issue has not been resolved but I will continue to struggle with it on my own and on Dolphin forums. I greatly appreciate the help. It's for a toddler, that I am doing this for by the way.

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts