Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Flattr, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
ResidualVM: play The Longest Journey on Linux
legluondunet commented on 1 July 2018 at 11:28 am UTC

do you know ResidualVM? It's a ScummVM like open source software but for 3D adventure games.
I tried it yesterday, it becomes stable and usable:
compiled from git on Ubuntu 18.04 --> OK
launched --> OK
tested The Longest Journey (Steam version) --> OK

It's a good way for Linux users to play The Longest Journey.

You can also play this adventure games:
Grim Fandango
Escape from Monkey Island
Myst III

tuubi commented on 1 July 2018 at 11:36 am UTC

As an adventure game fan I've been following it with interest since it was launched. For Grim Fandango, you'd be better off with the native remaster though.

Avehicle7887 commented on 1 July 2018 at 2:13 pm UTC

How could I miss this, I've been wanting to play The Longest Journey on Linux for so long, this is more than I could really ask for.

tuubi commented on 1 July 2018 at 2:30 pm UTC

Avehicle7887How could I miss this, I've been wanting to play The Longest Journey on Linux for so long, this is more than I could really ask for.
You should let them know.

Be warned though, their TLJ TODO is still quite long and support seems to be far from complete. Maybe you could help with testing and bug reports?

docpariolo commented on 1 June 2019 at 4:57 pm UTC


Sorry for reviving an old thread, but I am running into issues setting up.


Trying to ./configure from git clone directly (as per today, 1st june 2019) and running into this (i mean the LATEST problem I ran into that googling didnt solve)

Quoteaudric@debian:~/residualvm$ ./configure --prefix=/usr/local/ --enable-verbose-build --enable-sndio --enable-release --enable-c++11
Running ResidualVM configure...
Looking for C++ compiler... g++
Checking for compiler version... 6.3.0, ok
Building as C++11... yes
Checking best debug mode... -g + split DWARF + Gold + var tracking
Checking for whether C++ compiler accepts -Wglobal-constructors... no
Checking for whether C++ compiler accepts -Wno-undefined-var-template... no
Checking for whether C++ compiler accepts -Wno-pragma-pack... no
Checking endianness... little
Checking 64-bitness... yes
Type with 1 byte... char
Type with 2 bytes... short
Type with 4 bytes... int
Type with 8 bytes... long
Alignment required... no
Checking host CPU architecture... x86_64
Checking hosttype... linux-gnu
Looking for sdl-config... /usr/bin/sdl-config
Checking for SDL_Net... no
Checking if host is POSIX compliant... yes
Checking if posix_spawn is supported... yes
Checking whether to have a verbose build... yes
Checking whether building plugins was requested... no
Checking for pkg-config... yes
Checking for Ogg... no
Checking for Vorbis... no
Checking for Tremor... no
Checking for FLAC >= 1.0.1... no
Checking for MAD... no
Checking for ALSA >= 0.9... yes
Checking for libjpeg >= v6b... yes
Checking for PNG >= 1.2.8... yes
Checking for libtheoradec >= 1.0... skipping. no vorbis
Checking for libfaad... no
Checking for SEQ MIDI... no
Checking for sndio... yes
Checking for TiMidity... no
Checking for zlib... yes
Checking for libmpeg2 >= 0.4.0... no
Checking for liba52... no
Checking for libcurl... no
Cloud integration... no
Checking for FluidSynth... no
Checking for readline... skipping (text console disabled)
Checking for libunity... no
Checking for FreeType2... yes
Checking for GL Extension Wrangler (GLEW)... no
Checking for OpenGL... yes (shaders disabled)
Checking whether iconv.h is present... yes
Checking whether iconv needs linking against libiconv... no
Checking signature of iconv... iconv_t, char **, size_t *, char **, size_t *
Checking for iconv... yes
Checking for Linux CD-ROM... yes
Building translation support... yes (with runtime language detection)
Building taskbar integration support... no
Building system dialogs support... no
Building Bink video support... yes
Building updates support... yes
...disabling support for video cutscenes in PS2 version of Escape from Monkey Island. mpeg2dec is required
Backend... sdl (1.2.15), savegame timestamp
WARNING: Disabling engine The Longest Journey because the following dependencies are unmet: OpenGL with shaders

Engines (builtin):
Grim [all games]
Myst 3

Engines Skipped:
The Longest Journey

Creating config.h
Creating engines/
Creating engines/plugins_table.h

The only thing I found directly related was somebody else running into the issue, and solving it, on a bsd box.. So his/her instructions are most likely not going to work and I am not really willing to break my install trying it. Also my patience is pretty low, I admit.

Issue / BSD fix:

Any help will be greatly appreciated

whizse commented on 1 June 2019 at 8:01 pm UTC

I can configure and build using ed2143041403451c4fae54d1f0439705007317c6

Looks like one difference is that I'm using SDL2, which it should use by default? Check to see if you have the necessary dev packages installed.

There are some new commits made today (specify git commit instead of date!) that specifically mentions fixing build problems with SDL1, maybe that is your problem?

legluondunet commented on 2 June 2019 at 7:47 pm UTC

Hello Docpariolo,
you need to install libglew libraries and development packages to compile ResidualVM with Stark engines.
What is your distribution? On Ubuntu I installed this libraries:
libglew1.10 libglew1.6 libglew1.7 libglew1.8 libglew2.1 libglew-dev libglewmx1.10 libglewmx1.13
But I don't know which one is a true dependency.
I just update my build from git, it compiled ok.

docpariolo commented on 5 June 2019 at 9:04 am UTC

hey guys

thank you for the answers

I am using debian 9. Sorry to not mention it before.

But that is the end of the troubleshooting for me as I got it "fixed" like this:

That is vmware which does have 3d acceleration. And even on windows the game is quite glitchy. Just by forcing window mode (DUH. So basic) even the funcom intro logo does not appear. If it was just the intro logo.. I wouldnt be mad about it. But also the prologue text intro. And I dont know about any further; but it looks to me that all cutscenes alike would be affected. As this (will) be my first experience, I dont want to miss so many things. So vmwared windows 7 it is. For now at least.

legluondunet commented on 5 June 2019 at 9:48 am UTC

Play game on VMWare, not a very confortable solution, it's the last solution for me when there are nothing else.
Just install dependencies and compile ResidualVM will be a far better solution. If you don't want to bother with compilation, did you think to download binaries for your distribution here:

legluondunet commented on 12 June 2019 at 6:37 am UTC

If you own the Gog version, I wrote a Lutris script for this game, it uses ResidualVM, you will find it here:

legluondunet commented on 2 September 2019 at 12:00 pm UTC

Someone tried TLJ HD mod?

You need to Register and Login to comment, submit articles and more.

Or login with...

Livestreams & Videos
Community Livestreams
Popular this week
View by Category
Latest Comments
Latest Forum Posts