You can sign up to get a daily email of our articles, see the Mailing List page!
DIABLO on Linux
Page: «5/8»
  Go to:
legluondunet 15 Sep, 2019

Hello,

today DevilutionX 64 bits is finally promote "stable":
https://github.com/diasurgical/devilutionX/commit/c52464d2278660cbfe6c23ea48d31d82882d205b

So I wrote a Lutris Script which "automagically" install Diablo Gog version with the last DevilutionX 64 bits version.
You will find it here:
https://lutris.net/games/diablo/
installer name:
Linux GOG + DevilutionX Linux 64 bits version

- Dependencies: You have to install libsdl2-2.0-0, libsdl2-ttf-2.0-0, libsdl2-mixer-2.0-0 libraries.
- Please report issue concerning this script on my github page:
https://github.com/legluondunet/MyLittleLutrisScripts/tree/master/Diablo

Dedale 16 Sep, 2019

The windows 32 bits version of devilutionX works fine on my rig with WINE. So i post this just in case someone is curious about it.

I tried to run the Linux version. I downloaded a build here: https://github.com/diasurgical/devilutionX/releases

I suspect it is a 32 bits build. But i haven't seen another one. Maybe i am just too thick. :D

And i read this:

Quote*Note: Since 64-bit builds are currently not in a playable state, it is advised to build in a 32-bit environment. Another possibility is a 32-bit build on a 64-bit system (see above).*

So maybe there aren't 64 bits builds to download.

After i tried :
sudo apt-get install cmake g++ libsdl2-mixer-dev libsdl2-ttf-dev libsodium-dev

I got this:

Quotelibsodium-dev est déjà la version la plus récente (1.0.16-2).
libsdl2-mixer-dev est déjà la version la plus récente (2.0.2+dfsg1-2).
libsdl2-ttf-dev est déjà la version la plus récente (2.0.14+dfsg1-2).
cmake est déjà la version la plus récente (3.10.2-1ubuntu2.18.04.1).
g++ est déjà la version la plus récente (4:7.4.0-1ubuntu2.3).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
ethkey libargtable2-0 libboost-random1.58.0 libboost-regex1.58.0
libboost-thread1.58.0 libcryptopp-dev libeidviewer0 libethereum
libgtop2-common libjsonrpccpp-client0 libjsonrpccpp-common0
libjsonrpccpp-server0 libleveldb1v5 libllvm6.0 libllvm6.0:i386 libllvm7
libllvm7:i386 libmicrohttpd10 libnvidia-common-390 libnvidia-common-396
libnvidia-common-418 libnvidia-common-430 libqt5webengine-data
libqt5webengine5 libqt5webenginecore5 libre2-4 libwayland-client0:i386
libwayland-server0:i386 miniupnpc phantomjs python3-pyxattr
qml-module-qtquick2 qml-module-qtwebengine rlp rtmpdump
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.

And as usual after ./devilutionx

Quote./devilutionx: error while loading shared libraries: libSDL2_ttf-2.0.so.0: cannot open shared object file: No such file or directory

I am still somewhat curious on the why i cannot run what i think is the 32 bits build. :P

legluondunet 16 Sep, 2019

Hello Dedale, could you try this package:
https://github.com/legluondunet/MyLittleLutrisScripts/raw/master/Diablo/devilutionx-linux-64.zip
It is the last DevilutionX 64 bits version recently promute to stable and compiled by myself.
It's the one I use for my Lutris installer.

Dedale 16 Sep, 2019

Hello gluon du net !

Thank you for compiling it. But it seems that i am cursed. :D

Quote./devilutionx: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./devilutionx)

A little bit of googling suggests that (X)ubuntu 18.04 is not up to date enough go figure.

An example i gathered from there by googling the name of the lib: https://github.com/electron/electron/issues/18181

QuoteFYI it works for me on Ubuntu MATE 18.04 (x86_64) (which shares most packages with Ubuntu 18.04) using glibc 2.29-0ubuntu2.

EDIT: Sorry, my mistake! That was on 19.04. 18.04 has glibc 2.27-3ubuntu.

One lives and learns i guess. ^_^

P.S. I will try later on manjaro. If i understood well enough that should work.

legluondunet 16 Sep, 2019

I compiled it on Ubuntu 19.04...

Other thing: your 32 bits build didn't launch with this error message:

Quote./devilutionx: error while loading shared libraries: libSDL2_ttf-2.0.so.0: cannot open shared object file: No such file or directory

Try this command line:
sudo apt-get install libsdl2-2.0-0:i386 libsdl2-ttf-2.0-0:i386 libsdl2-mixer-2.0-0:i386 libsodium23:i386

you installed 64 bits libraries packages but you need the 32 bits libraries version too.

Dedale 16 Sep, 2019

Oooooh !

The Linux 32 bits works ! Aleluiah ! :D

And now i have a non garbled sound and even faster loading screens ! And the character from the windows version works on the Linux build !

Congratulations on solving my problem ! :)

And a great thanks for your kindness, patience and persistence ! Look how many of those "Huh it doesn't work" posts i have left here ! :P

legluondunet 16 Sep, 2019

Happy to help. I will ask DevilutionX devs if it is possible to compile DevilutionX 64 bits in a more portable way.

legluondunet 16 Sep, 2019

Dedale I modified my DevilutionX compile options, would you test it and say me if it still need a newer glibc?

https://github.com/legluondunet/MyLittleLutrisScripts/raw/master/Diablo/devilutionx-linux-64.zip

Dedale 17 Sep, 2019

It says me the same thing.

Quote./devilutionx: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./devilutionx)

legluondunet 17 Sep, 2019

Thank you Dedale for your test, the dev has suggested me to compile it on Ubuntu 18.04 or Debian 9 to obtain a build compatible with more distribution, that is my next step.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!

You need to Register and Login to comment, submit articles and more.


Or login with...

Livestreams & Videos
Community Livestreams
Latest Forum Posts