Cyberpunk 2077 in Wine
Page: «27/30»
  Go to:
rustigsmed Oct 15, 2023
anyone getting terrible audio at times (most of the time)?
Shmerl Oct 16, 2023
Audio issues can be hardware specific. Are you using pipewire by the way?
Xpander Oct 16, 2023
Zero issues with audio. Pipewire with USB DAC.

Also looks like holo-call fps drops got workaround in DXVK:
https://github.com/doitsujin/dxvk/commit/552d2f0a6d5c5710124ce921d5f9e132082c584a

Last edited by Xpander on 16 October 2023 at 5:35 am UTC
rustigsmed Oct 16, 2023
no I'm on pulseaudio 16.1 steelseries arctis 7 / default sample s16le 2ch 44100Hz. no issues with any other game or program, and only since phantom liberty. seems to kick off in louder environments - I thought it may be a Khz setting.
Shmerl Oct 16, 2023
You can try pipewire for a test. It can help in some of such cases.

Last edited by Shmerl on 16 October 2023 at 6:08 am UTC
rustigsmed Oct 16, 2023
Quoting: ShmerlYou can try pipewire for a test. It can help in some of such cases.
Cheers - went with pipewire and gave a quick test seems to be ok. looks like pipewire is at 48000Hz which may have been the issue with pulse being set at 44100Hz.

Cheers!
Shmerl Oct 26, 2023
Major performance degradation on the latest update to CP2077. GPU is loaded like only to 75% for me now resulting in worse framerate. Not sure what's causing it.
Xpander Oct 27, 2023
Quoting: ShmerlMajor performance degradation on the latest update to CP2077. GPU is loaded like only to 75% for me now resulting in worse framerate. Not sure what's causing it.

No change in performance for me. proton-experimental, nvidia 545 drivers. 5800X3D and RTX 3080.
You have a cpu with 2 CCX right? try the SMT toggle in the cyberpunk menus i guess, maybe that is the cause?
Shmerl Oct 27, 2023
I tried enabling SMT in the settings - that made it much worse actually for whatever weird reason. Keeping it on auto like before degrades it around 25% for framerate, since GPU utilization went from 100% to 75%.

Last edited by Shmerl on 27 October 2023 at 6:05 am UTC
Xpander Oct 27, 2023
Quoting: ShmerlI tried enabling SMT in the settings - that made it much worse actually for whatever weird reason. Keeping it on auto like before degrades it around 25% for framerate, since GPU utilization went from 100% to 75%.

What about if you disable SMT?
or use the WINE_CPU_TOPOLOGY=8:0,1,2,3,4,6,7 for example or some other combination that fits your CCXes
you can check this stuff with lstopo to see how your CPU is setup with CCXes

Not sure ofc if thats the issue but worth a shot i guess. But yeah i seem to have even slightly better fps to be honest..at least in super crowded areas. And GPU usage doesnt drop below 95% unless i cap the framerate to lower fps , which is excpected then.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone! Patreon supporters can also remove all adverts and sponsors! Supporting us helps bring good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register


Or login with...
Sign in with Steam Sign in with Google
Social logins require cookies to stay logged in.