Join us on our own very special Reddit: /r/Linuxers
Black screen/no video problem in different games
De1m0s 12 Sep

Hallo
i have the problem with Wasteland3 and Blasphemous, as many other people (see protondb), that the games do not display any videos. In these 2 games, you can´t continue when the video can´t be played.
For both games, most of the users on protondb wrote, that the use of the gloriousEggroll-Proton-release will fix the problem. For other people (like me) this doesn't work.
I´m trying since days to find a solution.
There must be a difference, if this works for most of the users, and for others it doesn´t.
I have both games purchased at steam, tried the official proton releases as well as the gloriousEggroll ones.
Then i tried installing wmp11, no success (wmp11 runs, but no videos in the games)
Tried installing z0z0z0-media-pack (https://github.com/z0z0z/mf-installcab), still no videos.
Tried installing the media-features as described here:https://askubuntu.com/questions/651099/how-to-install-windows-media-feature-pack-required-by-a-game
i guess this can´t be done with success, because regsvr32 needs administrator-rights, which can´t be done in wine.

Anyone has an idea, what to try next, or could anyone fix the problem.

System is Linux Mint 19, GTX970 with newest nvidia-drivers, CPU is Ryzen 1700.
In linux, i can play the videos, no matter they are in .ressource-format.

Thanx for every tip.

Last edited by De1m0s on 12 September 2020 at 10:53 am UTC

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.