Join us on our own very special Reddit: /r/Linuxers
Amazon's Luna sort of works on linux
ShinyaOsen 19 Nov, 2020
I was looking at my email and saw that I was accepted for Luna early access so I spent most of my morning trying it out and this is what I found.

I Live in the US in Pennsylvania so I don’t know how other places will be like but the latency was like Geforce Now so fine not great but not bad and the picture quality was the same as Geforce Now.

First off you need to spoof your user agent so you can play or else you'll get this.

Second it doesn’t work in Firefox I expected this since it say they don't support it but for fun I spoofed it to look like chrome and got this.

Here is what I try it out on
Desktop Manjaro unstable: Degoogled Chromium, Brave, Chrome

Laptop Opensuse Tumbleweed:Chromium, Brave

Controllers used Xbox one wired, PS4 wired, 8bitdo receiver, PS4 over bluetooth(Opensuse)

I didn’t test Xbox 360 and Xbox one over bluetooth because I was getting bored and I forgot how to pair my Xbox one controller to bluetooth

I have a youtube video of me trying it out for the first time
Music I was listening to was from b e g o t t e n 自杀

In the video I tried Control(beginning-18:00) worked, Bloodstained Ritual of the Night(18:14-20:21) controller input didn't work, Metro Exodus(20:53-28:49) worked but for some reason in 16:10 and Abzu(29:05-End) controller input didn’t work I was using the 8bitdo receiver in the video and half way though I unmuted my mic by mistake.

Notes I have

Not sold in Japan(I was looking at stuff on OTOTOY before and was using a VPN to get around region lock and forgot to turn it off that's how I found this out)

In all browsers using keyboard and mouse would cause the panels in KDE to appear

2 controllers and keyboard all worked at the same time in overcooked 2 (Chrome didn’t test others Used 8bitdo and Xbox one controller)

Brave doesn’t work on Manjaro wont load Games
Brave works in Opensuse

Input form Bloodstained and Abzu worked in Degoogled Chromium(Manjaro 8bitdo and Xbox one wired) and Chromium(Opensuse 8bitdo and PS4 wired)

Overcooked 2 8bitdo input broken (Opensuse Brave) PS4 over bluetooth works

Bloodstained PS4 over bluetooth not working (Brave Opensuse) 8bitdo works

Bloodstain in general felt choppy to me but probably because I'm used to playing at 144Hz instead of 60Hz this was also the only game on Luna that I'm familiar with seeing how its the only game on the service that I own
Liam Dawe 20 Nov, 2020
I have to wonder what it is that Firefox is missing or not doing that won't let these streaming services work.

Nice to know that at least with a Chromium browser it will though.

QuoteIn all browsers using keyboard and mouse would cause the panels in KDE to appear
That happens with Stadia too, KDE is quite annoying on how it likes to display on top of full-screen stuff :(

Sounds like Stadia is still going to be better on Linux.
ShinyaOsen 20 Nov, 2020
Quoting: Liam DaweI have to wonder what it is that Firefox is missing or not doing that won't let these streaming services work.

I just tried Firefox beta 84.0b3 and Firefox ESR 78.5.0esr both on Manjaro because I though that maybe an extension I had was blocking something Luna needed.

Still had to do the spoof on both of course.

Firefox ESR didn’t work.

Firefox Beta worked but I couldn't get controllers to work and I didn't have any problems with KDE panels when using the keyboard.

I want to test normal Firefox on linux and windows but my friends called early to do stuff so I'll get back to this.

Last edited by ShinyaOsen on 20 November 2020 at 10:35 pm UTC
ShinyaOsen 21 Nov, 2020
So I did more testing in Firefox the KDE panel thing doesn't happen so you can play the games with mouse and keyboard perfectly fine that about the only thing that's better then chromium based browsers.

Windows Firefox stable and beta

TLDR: Controllers are a mess and I don’t understand it, sometime they work, other times they don’t or they prevent any input from working.

Manjaro Firefox stable and beta

Controllers don't work but doesn't prevent inputs from being registered so that’s a plus.

I also tried Geforce Now on Firefox in Manjaro and same problem as Luna but now the mouse doesn't work. So I'm going to take a guess and say that the reason they don't use Firefox is that controllers don't really work and they don’t want to fix the problem since it works in chromium based browsers or Firefox needs to fix the problem.

Last edited by ShinyaOsen on 21 November 2020 at 5:07 am UTC
kibasnowpaw 16 Dec, 2020
i am not a fan of cloud gaming since it really depending on your network and you need to have a stable connection.
i have not Tried Amazon yet but I didn't like Geforce Now. if I really want something like that I would set up my own steam pc and use the steam link to play on instead work better and is fully controller supported.
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.