Check out our Monthly Survey Page to see what our users are running.
Input stuttering and Jittery movement when playing games on Steam Play with Proton on Kubuntu20.04
Page: 1/3»
  Go to:
Jeremy 28 Nov, 2020

My System Info

Linux Distribution: Kubuntu 20.04 LTS
Desktop Environment: KDE 5.18.5
Graphics Card: Nvidia GeForce 1050 Ti
GPU Driver Version: 455.45.01

Have you checked for system updates?: [Yes/No]

If this is to do with Steam, please add your system read-out from Steam -> Help -> System Information (please put that into Pastebin/Gist as linked above!): https://pastebin.com/ZxFWQHPx


You can note your issue below here

I have recently switched to Kubuntu and have setup Steam with Proton 5.13-2 and installed the Nvidia proprietary drivers.

When i go play a game no matter which one it is (example: it happens in GTA5 and Killing Floor) sometimes when i press and hold the "W" key (or any other movement key) the character randomly stops or starts having very Jittery movement almost as if the input is being registered only every other frame.

Also sometimes the mouse position will change in a sudden burst to a random direction ( like when playing Killing Floor i will suddenly aim to the sky when trying to aim at the enemies), it doesn't happen all that often but it does happen from time to time.

The frame rate doesn't drop and everything that is not movement related works fine. I checked the keyboard settings and it doesn't seem that any setting is what causes the problem. It's sad because i was so excited with how well everything else was working without requiring much effort.

Anyone has an idea of what may be causing this and what i can do to fix this? Haven't found anyone with the same problem on the internet when searching.

Thanks in advance!


Note any particular steps to reproduce it below here

I don't know what one would do to reproduce this, i have just done a normal install of Kubuntu20.04, installed the drivers i thought i should install and booted up Steam to play my games with Proton. It really is a strange problem i don't see anyone else having and i don't know of anything i have done that may have caused it.

stan 29 Nov, 2020
  • Supporter

Tried with another keyboard / mouse / mouse pad ?

Jeremy 30 Nov, 2020

Quoting: stanTried with another keyboard / mouse / mouse pad ?

I don't have another keyboard, neither another mouse.

I tried running a non-Steam game (Witch Hunt) using only wine and after clicking "new game" the world loaded up but the keyboard and the mouse stopped working entirely. The terminal started inputting this non stop:
0032:err:d3d:wined3d_debug_callback 0x109dce80: "GL_INVALID_FRAMEBUFFER_OPERATION error generated. Operation is not valid because a bound framebuffer is not framebuffer complete.".
0032:fixme:d3d:wined3d_context_gl_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_LAYER_TARGETS (0x8da8).
0032:fixme:d3d:context_dump_fbo_attachment GL_DEPTH_ATTACHMENT: 2d texture 1834, 1024x1024, 0 samples, format 0x81a5.
0032:fixme:d3d:context_dump_fbo_attachment GL_STENCIL_ATTACHMENT: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT0: 2d-array texture 1830, 1024x1024, 0 samples, format 0x822e.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT1: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT2: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT3: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT4: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT5: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT6: NONE.
0032:fixme:d3d:context_dump_fbo_attachment GL_COLOR_ATTACHMENT7: NONE.

Maybe it is a Witch Hunt only problem but it seems to be related because both problems involve the keyboard and mouse even though at least on Steam the keyboard and mouse still worked somewhat.

Guppy 30 Nov, 2020

And if you play a native game this doesn't happen?

Xpander 30 Nov, 2020

if i was you, i would try another window manager or desktop enviroment first to see if the problem goes away.
The log for Witch Hunt indicates you dont even use DXVK on thisone, but the regular wined3d which is using opengl. So this log might have nothing to do with the other issues. Proton defaults to DXVK for all dx9, dx10 and dx11 games. Now if it was a mouse issue only i would suggest trying to lower polling rate of your mouse, as i remember some people had issues with 1000hz polling for some reason, but since you also have keyboard input issues, i think thats not the problem.

Long story short.. try other Desktop Environment or even LiveUSB distro like PopOS or Manjaro that comes with nvidia drivers by default so you could just run some test game on live environment to see.

Last edited by Xpander on 30 November 2020 at 12:26 pm UTC

Ehvis 30 Nov, 2020

From my experience this happens with an nvidia card with bad compositors. Last time I checked, the kwin compositor still fell into that category. IIRC, there is a setting to change kwin to use xrender (ask a kde person for more detail), which could potentially alleviate the problem.

Jeremy 30 Nov, 2020

Quoting: XpanderThe log for Witch Hunt indicates you dont even use DXVK on thisone, but the regular wined3d which is using opengl. So this log might have nothing to do with the other issues.
Weird, i remember running the DXVK installer script on the wineprefix i used to run Witch Hunt. I must have done something wrong then...

Quoting: XpanderLong story short.. try other Desktop Environment or even LiveUSB distro like PopOS or Manjaro that comes with nvidia drivers by default so you could just run some test game on live environment to see.
Thanks for the advice! i probably will try using the liveUSB as i don't know how to change the Desktop Environment, and besides i was contemplating distro hoping to PopOS or Manjaro anyways .

Jeremy 1 Dec, 2020

Quoting: JeremyThanks for the advice! i probably will try using the liveUSB as i don't know how to change the Desktop Environment, and besides i was contemplating distro hoping to PopOS or Manjaro anyways .

Just installed Pop!_OS. First thing i did was install Steam and then Killing Floor, the problem sadly persists .

Now it is slightly different, when i hold "w"(or any other movement key) the character seems to slide more than being jittery but it is very slow and it keeps moving for a while after i stop pressing the key. if i press any other key like space to jump it will sometimes take a while to register the input if the character is already "sliding".

I will install more games to test with Proton, and some native Linux games as well, but now i don't know what is the problem if it wasn't something with KDE or my Kubuntu install .

Xpander 1 Dec, 2020

do you have some sort of oddball usb hub maybe?
or maybe some bizarre bios option that does something to the usb ports?

maybe your keyboard just releases the button straight after you pressing it down.
like every press you make is instantly press down and release.

but then that should come up with typing also then i think.

Jeremy 1 Dec, 2020

Quoting: JeremyI will install more games to test with Proton, and some native Linux games as well, but now i don't know what is the problem if it wasn't something with KDE or my Kubuntu install .

I have tested many games and all of them (regardless of being native or through Proton) had problems with holding down keys, instead of a continuous input it appears to give many short inputs.

When i tried to play Team Fortress 2 ( native Linux game) i coudn't move when i connected to the server, when i tried to move by holding down "W" i was kicked out of the server and this message appeared:

issued too many commands to the server

While testing other games like Hollow Knight and Metro 2033 i noticed that the problem extends to pretty much every key of the keyboard, while the mouse and the mouse buttons seem to work fine( as well as controller input).

Quoting: GuppyAnd if you play a native game this doesn't happen?
I have found out that it actually does happen with native games as well

Quoting: EhvisFrom my experience this happens with an nvidia card with bad compositors. Last time I checked, the kwin compositor still fell into that category. IIRC, there is a setting to change kwin to use xrender (ask a kde person for more detail), which could potentially alleviate the problem.
Well, now that i'm using Pop!_OS could this still be the problem? if so how could i go about solving it?

Jeremy 1 Dec, 2020

Quoting: Xpanderdo you have some sort of oddball usb hub maybe?
or maybe some bizarre bios option that does something to the usb ports?
Not that i know of.

Quoting: Xpandermaybe your keyboard just releases the button straight after you pressing it down.
like every press you make is instantly press down and release.

but then that should come up with typing also then i think.
I would believe that's the case, but when i'm typing i can hold down any letter i wish for as long as i want.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
None currently, submit yours here!
Latest Forum Posts