Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can donate through PayPal, Liberapay or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
[SOLVED] Reboot doubles FPS
Page: 1/2»
  Go to:
eiseneuter 16 Dec, 2020

Gaming Laptop, Manjaro KDE, 32gb RAM, NVidia drivers latest, RTX2060 mobile, Lutris, Steam, Gamemode, DXVK, GE Proton latest

It's just annoying. Opening a game in a running session (several hours) will make it perform poorly.
Rebooting the system doubles my FPS, but can't be the solution.

Game: The Suicide Of Rachel Foster, opened through Steam
Running Session: 30fps, constant framedrops, slow movement
After reboot: 60fps, occasional framedrops

Tried closing all programms, disconnecting network drives. Plasmashell & Xorg occupy half the space after Reboot, but theres 32gb for

Has anyone experienced the same & a possible solution?

Thanks dudes and dudettes!

EDIT How to reproduce the lag
Unplugging the Laptop (while in KDE desktop) from power results in a massive performance drop (as intended I guess). (Nvidia Settings - Powermizer - Performance Level 0 and 1)
Plugging the Laptop back in would not restore whole previous performance -> Lag until reboot (Nvidia Settings - Powermizer - Performance Level jumping between 4 and 2)

finally [SOLVED] it:
Found this posting to force Low-Performance Settings, but indeed the same settings (Parameter 0x3) solved my problem with Performance Level jumping and thus creating system lag after plugging the laptop to AC again.
Works as intended: Laptop back on AC - Performance Level 4 constant

- edit / create file:

sudo nano /etc/X11/xorg.conf.d/20-nvidia.conf

(you may choose your favorite texteditor instead of nano)

- edit /paste in file:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “Coolbits” “1”
Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3”

- reboot

Last edited by eiseneuter on 9 January 2021 at 6:26 am UTC

This topic has an answer marked - jump to answer.
denyasis 17 Dec, 2020

So, I've had something similar happen to me twice, where I got weird slow downs and the COU and RAM were barley being used. They were both network related.

You mentioned network drives. Do you use NFS by chance? A few years ago, had this problem on Debian testing on my laptop. Best I could figure, it looked like NFS was trying to connect/reconnect/find the server and things would wait for it, particularly if I was browsing for files.

Maybe you have a process that's doing a lot of network or IO work? Could be holding things up?

Sadly, I never figured it out and ended up distro hopping (for other reasons), where the problem went away. The network is mostly magic to me.

I hope that gives you a place to look.

Last edited by denyasis on 17 December 2020 at 12:28 am UTC

furaxhornyx 17 Dec, 2020

Yes, it has happened to me several times already, on titles like Elex and Greedfall.
I haven't noticed this recently, but I have been playing less demanding games (currently playing Iratus, for example).

Sadly, I have no solution to offer. I tend to notice that it had more chances of occuring after watching some videos on firefox, so it may be related to hardware decoding, not releasing all resources when done.

eiseneuter 17 Dec, 2020

Thanks for the suggestions. I set up NAS drives, nothing going on with NFS...i guess.
As for a network traffic monitor, I didnt find a tool to easily see whats going on. Is there a non command-line-based a simple gui-monitor?

DigitalSin 17 Dec, 2020

Quoting: eiseneuterThanks for the suggestions. I set up NAS drives, nothing going on with NFS...i guess.
As for a network traffic monitor, I didnt find a tool to easily see whats going on. Is there a non command-line-based a simple gui-monitor?

Since you're using KDE I suggest KSysGuard...

eiseneuter 18 Dec, 2020

Quoting: DigitalSinSince you're using KDE I suggest KSysGuard...

Ahhh right, it has up-and download columns i didnt recognize ;)

Couldn't solve it yet -_-

eiseneuter 18 Dec, 2020

it's so frustrating. Still, the performance difference is immense. Same programs opened in the background.

17 fps before reboot
before reboot

60 fps after reboot
after reboot

Fiddled around with the compositor, but no luck here. No significant network traffic. What processes could slow down the performance in such a manner?

Last edited by eiseneuter on 18 December 2020 at 9:21 pm UTC

ageres 19 Dec, 2020

Overheat maybe?

denyasis 19 Dec, 2020

Interesting, from the overhead, it looks like the GPU is your bottleneck.

Throttling due to heat might be a possibility as agreed said.
Or something could be using cpu in the background.

I think there is a process monitor for nvidia, nvidia-smi (I had to Google that). If the nvidia control panel doesn't give anything illuminating in regards to heat or performance level, it might be worth a look.

From the internet searchings, it looks like :

watch -n 0.5 nvidia-smi pmon -c 1

Might be what you need. I won't be near my computer (an older nvidia machine) to check it out in my own, so the usual cautions with CLI commands from some website apply.

I hope that helps.

eiseneuter 20 Dec, 2020

I don't think that overheating is the problem, but i will take a closer look.

Thanks for the effort you made to help!
Checked the suggested GPU Monitor and there are three applications that give me values:
- "Overlook-Win64-" most probably the game itself, running with Proton (constant)
- Xorg (occasionally)
- Brave browser (occasionally)

This time, even after the now all-day-session without reboot, the game ran smooth. Kind of surprising, It's hard to recreate the behavior. Will take another look, when it bugs out on me again.
Thanks for the deep look, always learning new things!

Last edited by eiseneuter on 20 December 2020 at 1:46 am UTC

denyasis 20 Dec, 2020

Glad it's working for you,hopefully bit temporary. Also, sorry I don't have much else int the way of suggestions.

Only thing that came to mind this morning, it could be a case of a bug somewhere in the software.

Assuming this happens with other games, it could be some freak bug that pops out when running proton, dxvk, lutris, and game mode.

The nice thing with the translation stack is that most of it is replaceable or optional (hopefully). Depending how deep you want to get, you could try using regular proton or wine, disable ganemode, toggle dxvk, etc.

The downside to trying that is changing all of those may effect performance and stability of your game, so you could end up changing one problem for another, which is more annoying than anything.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.