Join us on the Linux Gaming community on Lemmy, the federated open source alternative to Reddit.
ELEX on wine
Page: 1/2»
  Go to:
cruc2019 27 Feb
Hi to all. I am running the game ELEX (GOG version) on the latest development version of wine with DXVK installed (Ubuntu Mate 20.04, Ryzen 2600 and an AMD RX 570). The game runs just fine on high settings, but the behavior of the graphics card is strange. The fans stop completely for a few seconds and then spin at maximum speed for a few seconds and that repeats all the time. No other game that I am running under wine has this behavior. If anyone knows why this is happenning I would be grateful.
furaxhornyx 28 Feb
I used Steam / Proton to play Elex, and I didn't have any problems, but I remember reading several time that there was a graphical setting to lower, to be able to play correctly. I don't remember which one, but I think it was shader quality, or shadows quality. Maybe try to lower those settings and see if the problem still occurs ?

Also, at least with Proton, the first time you launch the game, shaders need to be compiled (whatever that means ), and if you start playing immediately, it can cause stuttering.
cruc2019 28 Feb
Thanks furaxhornyx for your time. I tried the settings at their lowest value, but nothing changed. The fan speed is controlled by the driver, isn't that true? How can the game bypass that. I don't know. Very strange...
tuubi 28 Feb
Does it help if you run the game with gamemode? Maybe setting the GPU to performance mode explicitly makes it behave more consistently.

I don't think the game is bypassing anything. I guess it's just stressing the GPU in a strange pattern.
cruc2019 28 Feb
Hey tuubi. Isn't gamemode only for native linux games? Can I use it under wine? Thank you very much for your input.
tuubi 28 Feb
I don't see why gamemode wouldn't work with Wine games. Try this:
gamemoderun wine whatever.exe
cruc2019 1 Mar
I used gamemode and the game hangs on a black screen. Sometimes computers can drive you crazy!...
Maybe you can try CoreCtrl to tweak your GPU performance profile ?

Also, if you have an "overclocked edition" of your GPU, maybe you can try setting frequency and voltage back to "factory" settings (look for your GPU model on AMD site, the specs should be there). I know I've had some trouble in the past with some OC edition of GPU (granted, I was using Windows, but bad overclocking is bad on any platform).
tuubi 2 Mar
Quoting: furaxhornyxMaybe you can try CoreCtrl to tweak your GPU performance profile ?

Also, if you have an "overclocked edition" of your GPU, maybe you can try setting frequency and voltage back to "factory" settings (look for your GPU model on AMD site, the specs should be there). I know I've had some trouble in the past with some OC edition of GPU (granted, I was using Windows, but bad overclocking is bad on any platform).
I had similar trouble with my old (factory OC'd) MSI RX580, but I didn't have to touch the frequencies at all. Just lowered voltages a bit and it stopped crashing and ran cooler. That convinced me to avoid MSI in the future.
cruc2019 3 Mar
Well, my card is not overclocked. When I ran the game with high settings the temperature does not go above 55 degrees Celsius (which I think is a normal temperature). I tried CoreCtrl but no difference. And I noticed that this behaviour continues after I quit the game and I am on the desktop. I must restart my computer for the fans to start behaving normally.
rojimboo 6 Mar
I doubt the specific game could alter anything about the fans behaviour - it's more likely they are just exposing something in the gpu fan profile by utilising it heavily. But of course, I could be wrong!

55 degrees celsius is abnormally low for running games. How did you measure this? Try MangoHUD overlay to see it in 'realtime' at load inside the game. It also gives you a bunch of other useful metrics, like CPU and GPU load. You can use goverlay to customise it conveniently, or just use the cfg files.

I can only speak for a Nvidia gpu (1070) but after I switched to Linux, I had to set my fan controls manually as the automatic setting basically meant they never went on (I discovered to my shock and horror). Now I have a 3rd party fan curve script that starts up at boot time and it's very aggressive giving me cooler temps yet more noise.

Just some quirks of gaming :)
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.