Join us on our own very special Reddit on /r/Linuxers.
alot of stutter from Dirt 5 and Steam Proton
Page: 1/2»
  Go to:
Samantha 23 Oct, 2021
Hi everyone, im trying to get Dirt 5 to work on linux mint steam proton, i got it to work on garuda but garuda felt very unstable, but on linux mint 20.2 kde im getting alot of unplayable stutter, ive tried googling and have tried various things but none of them seem to work, im all out of ideas, as far as my experience with linux, ive used linux off and on since like 2001, but my knowlege is limited, i finally made the full switch to linux thanks to steam proton, and not wanting another darn windows, anyway any fixes can you tell me as if im a newb, my head will think you :)
Xpander 23 Oct, 2021
shift+alt+f12 when in game to turn off compositor doesnt help?
Samantha 23 Oct, 2021
well note to self ctrl alt f12 wasnt a nice key combo, but shift alt f12 didnt seem to do anything, tho i shutdown the game to install obs studio and try to record how bad the stutter was, when i reloaded the game the stutter was better first race i did no stutter, second race 2 or 3 times and the 3rd race also 2 or 3 times, so i dont know if shift alt f12 and then rebooting the game helped, or if installing obs studio helped or just hitting the record button help idk, but it is better, still could use some improvement tho
Koopacabras 23 Oct, 2021
doesn't stutter for me it is butter smooth in fact. I don't use any tweaks. What is your hardware?, remember that on Linux, with Proton, you get a performance penalty of upto 30 ish percent depends on the game.
Also I don't mess with the graphics settings at all, I'm using what the game defaults to, which sometimes are very low graphics settings.
(Also you need Proton Experimental for this game, you have to right click on the game select properties and choose Proton Experimental in the compatibility tab)(you can search in the articles on the site, on how to install proton experimental)

Last edited by Koopacabras on 23 October 2021 at 3:58 pm UTC
Samantha 23 Oct, 2021
hi The_Aquabat, I dont think its my hardware, but i got a amd 3900x, 32gb memory, AMD 6600XT, and ssds all around, I am using proton experimental, the only thing i can think of is theres some dependency im missing, and also performance getts better with OBS running, which is weird. as far as what i have done so far, is i followed the lutris docs to install wine and gpu drivers, i installed gamemode, and i went through boilingsteams guide as well, and ive search google, i just cant figure out whats causing this issue, ive reinstalled mint after trying out garuda, i accidentally deleted the wrong partition, nvme1 vs nvme0 an easy over look for someone with mild dyslexia, but i did try garuda and then reinstalled mint which im on a fresh install. i havent tried any other distro i like mint cause it feels to run smoother compared to other distros ive tried. i could start installing others i suppose just to try them out for the game but it would be a shame if i cant get it to run smoothly on mint.
i suppose i could try ubuntu with wayland since i did ad wayland to my garuda kde, maybe thats the magic trick
denyasis 23 Oct, 2021
Did you get the stutter when you tried it with Lutris and normal wine? That could rule out it being a Steam Proton specific issue if it stutters for both.
Samantha 24 Oct, 2021
wel i tested lutris and still same issue and cant get wine to work with dirt 5 keeps asking to have steam open which i have open. i see The_Aquabat is running kubuntu according to their profile, im going to install kubuntu and another partition and see if its mint, cause garuda was better but mint has the stutter, so it makes me believe its something on mint side but we will see.
Samantha 24 Oct, 2021
well I installed kubuntu still have stuttering, then i installed arch linux which took me many many hours but it was a learning process which i really enjoyed :) but i still have the stuttering, i ran benchmarks and frame rated droped to 1 during the stutter, i can say dirt 5 is running better on arch then on mint or kubuntu, but still stuttering tho halfway playable. i made a youtube video to show the stuttering.

im going to tell everyone what i do to game, and you can feel free to tell me i missed something, im going to write what i did for kubuntu and mint which are similar, and easier to write and not as in depth as arch is :)

ok, after installation, i first install drivers using lutris docs guide

then i install wine again using lutris docs guide

then i use the guide from feralinteractive for gamemode

then i install steam
install the game through steam and thats pretty much it, i do some other stuff like installing a browser, discord, spotify, and any other software i need, and i spend alot of time customizing the looks of kde, i didn't do that in the video since i only installed arch to see if i could get it to to run without stutter but no luck so no need to keep arch installed.

if i missed anything please please let me know this is driving me crazy, all my other games run fine its just this game which is weird.
whizse 24 Oct, 2021
Are you sure it isn't the usual shader compiler stuff? Do you get less stutters if you re-run the game with the same settings/car/track/weather etc?
Samantha 24 Oct, 2021
Quoting: whizseAre you sure it isn't the usual shader compiler stuff? Do you get less stutters if you re-run the game with the same settings/car/track/weather etc?

nope ive ran it a few times and still same issue, i was going to try other kernals but it seems i got banned for 24 hours lol so cant try anything new till then

Last edited by Samantha on 24 October 2021 at 7:43 pm UTC
Koopacabras 25 Oct, 2021
You don't need to follow boiling steam guide anymore. It works OOTB with proton experimental. Also I use kisak ppa, that might help too.

But if you are running it on Arch based distros, which normally have more updated drivers, then I don't know what is your problem. As I said for me it runs fine with no tweaks needed with proton experimental. Maybe it's a regression in the Amdgpu driver but only affecting RDNA2 GPUS, could be that once I hit a performance bug on Desperados III that only happened on RDNA1 Gpus.
Maybe trying installing amdvlk driver is worth a shot. (it's an alternative driver to the default one for amd Gpus)
here you can download a deb package...

simply install with dpkg -i file.deb

then you have to add this to the launch options of the game

 VK_ICD_FILENAMES="/usr/share/vulkan/icd.d/amd_icd64.json" %command%
installing MANGOHUD could help too since that way it tells you what driver you are running, amdvlk or radv.

if it is really a bug on RDNA2 driver then you might want to report it, since the steam deck runs on RDNA2, I think that valve devs will look into this with a lot of interest.

(Also your card is a little faster than mine so it's not a problem with the hardware.)

Last edited by Koopacabras on 25 October 2021 at 8:56 am UTC
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: Liberapay or PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.