You can sign up to get a daily email of our articles, see the Mailing List page.
Mod Organizer 2 Skyrim can't find Steam
QoAaD 14 Jun
So frustrating! I tried installing MO2 through Lutris and it didn't even run. When I installed it using a Linux installer on github, it worked fine. Got everything working, installed mods, played for an hour or so. Then I shut it down. Now when I try to run Skyrim from MO2, it tells me "Cannot start Steam: The path to the Steam executable cannot be found. You might try reinstalling Steam." But it was working yesterday!

For reference, I'm on Mint 19.1 Tessa. My main Steam install is on my primary hard drive. I have a separate physical drive for my games. That's where Skyrim and MO2 are located. I can't find anywhere in the MO2 settings for the Steam path. Lot of other path settings, but not that, unless I'm being blind (always a possibility).

Help?
TheRiddick 17 Jun
Yeah you need to add MO2 as non-steam game to the Linux steam. Then configure the proton version you want. SYMLINK that skyrim/fallout whatever prefixes into the MO2 folder (or vise versa) and then you have a bound package to work with.

If you find you can't access specific drives inside the proton environment then you need to designate them with a proton resource path variable... Don't ask specifics as I forget. Been long time since I last used MO2 even thought it is the best! I just don't play Bethesda like games atm. (waiting until TES6 or Starfield)

Last edited by TheRiddick on 17 June 2022 at 5:36 am UTC
QoAaD 21 Jun
Thanks. I might poke around a bit further, but it's being more of a pain than I really want to deal with right now. If I decide to play it anyway, I might just install mods manually. But I have way too many games in my library, so this might to the back burner again.
scaine 22 Jun
This makes me wonder if the older Mint might be the issue here. I'm on Endeavour, which is essentially Arch, and MO2 worked okay for me on Lutris. You have to follow the instructions pretty carefully though, such as using Proton 5.0-10. I also had to delete my previous PFX folder (I use a separate game's drive, so when I re-installed MO2, it picked up the old version and failed). And remember to run Skyrim at least once before you start the Lutris install.

MO2 running via Lutris, showing Skyrim SE in Steam running via Proton 5.0-10

One more thing - I didn't buy Skyrim Anniversary Edition, but the SE version updates to use the new executable anyway, which means that you have to manually install the latest SKSE from github. Total pain, but it is nice to have Skyrim SE working again with all my mods.
TheRiddick 23 Jun
Yes you can use other launcher tools if you go via proton (to detect linux steam).
I just said adding as non-steam game to the steam client as it typically is easier for most people.

There is also Bottles tool you can use which has proton plugged in.

The benefit with Skyrim SE is its 64bit and can load in more then 4096MB of textures without going to HDD buffering external tool route. It also has better lighting.

Last edited by TheRiddick on 23 June 2022 at 12:30 am UTC
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: Liberapay or PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.