Support us on Patreon to keep GamingOnLinux alive. This ensures all of our main content remains free for everyone with no article paywalls. Just good, fresh content! Alternatively, you can donate through PayPal or Buy us a Coffee. You can also buy games using our partner links for GOG and Humble Store.
Bluetooth microphone not working
Supay 18 Sep
I have the Shure Aonic 50 headset. It has Bluetooth 5, and pretty much every codec out there. It works absolutely perfectly for headphone audio and sounds great. However, the microphone shows as unplugged in KDE and I just cannot get it to register that the headset has a working microphone. The headset works fine on my desktop, my phone, my laptop, and every other device I have tried it on, for both audio and microphone. I have tried every single codec available on the Deck, as my headset supports them all, with no change. Unpaired and repaired etc. It seems I am not the only one, as there are posts about this on Reddit and other areas.

I was hoping someone here may have an idea as to what the issue could be please? Though generally, Bluetooth does seem to be a work in progress matter for the Deck still as it struggles to reconnect at times, outright refuses to at others, and the audio sometimes goes wonky and requires a full reboot of the Deck.
While you're here, please consider supporting GamingOnLinux on:

Reward Tiers: Patreon. Plain Donations: PayPal.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.