Use Reddit? Join us on our very own subreddit: https://www.reddit.com/r/Linuxstuff/
You can sign up to get a daily email of our articles, see the Mailing List page!
Support us on Patreon to keep GamingOnLinux alive. This ensures we have no timed articles and no paywalls. Just good, fresh content! Alternatively, you can support us on Paypal and Liberapay!
  Go to:
[Fixed, needs testing] Dying Light refuses to launch
devland commented on 12 February 2018 at 10:25 am UTC

sr_ls_boyI get a bad stutter with the frame rate which makes it unenjoyable.
https://steamcommunity.com/app/239140/discussions/0/604941528477881594/
I tried that and it works.
You can also enable vsync in the config file manually without having the game crash while trying to do it in the options menu.

I am now trying to use exodus to get it running on antergos via the Linux Mint 18.3 packages.

devland commented on 13 February 2018 at 9:31 pm UTC

I've managed to pinpoint the problem to the "libc.so.6" library. I've pre-loaded the one from Linux Mint 18.3 and now I get the error

gdb: ./dependencies/libc.so.6: version `GLIBC_2.25' not found (required by dependencies/libpython3.6m.so.1.0)

when debugging with gdb.

Can anyone upload somewhere the 64 bit "libpython3.6m.so.1.0" file from Linux Mint 18.3 so I don't have to reinstall it just for one file?

tuubi commented on 14 February 2018 at 7:15 am UTC

devlandI've managed to pinpoint the problem to the "libc.so.6" library. I've pre-loaded the one from Linux Mint 18.3 and now I get the error

gdb: ./dependencies/libc.so.6: version `GLIBC_2.25' not found (required by dependencies/libpython3.6m.so.1.0)

when debugging with gdb.

Can anyone upload somewhere the 64 bit "libpython3.6m.so.1.0" file from Linux Mint 18.3 so I don't have to reinstall it just for one file?
libpython3.6 isn't available on Mint 18.3 / Ubuntu 16.04, but you can download the 64-bit libpython3.5 deb package here and extract the .so from the data.tar.xz if that helps. You can browse all the repository servers right in your browser, no need to install the distro.

devland commented on 14 February 2018 at 10:14 am UTC

tuubilibpython3.6 isn't available on Mint 18.3 / Ubuntu 16.04
I thought as much.
My guess is that the game requires another file, found it in the antergos lib folders, but it was a newer version that requires python 3.6 instead of 3.5.
I'll see if I can figure out who the culprit is.
The point is that the game runs on antergos & Arch via the Solus runtime. Pre-loading the libraries via a sh script does the same thing. You just need a full list of all required dependencies and their dependencies, and so on. And that's the hard part.

kaymio commented on 22 February 2018 at 1:16 pm UTC

After installing Solus and on it Steam as well as Steam via Snap it still doesn't work.

ERROR: ld.so: object '/home/gamer/snap/linux-steam-integration/common/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
GameAction [AppID 239140, ActionID 4] : LaunchApp changed task to Completed with ""
/home/gamer/snap/linux-steam-integration/common/.local/share/Steam/steamapps/common/Dying Light/DyingLightGame: /usr/lib/libcurl-gnutls.so.4: no version information available (required by libengine.so)

As it doesn't run on Arch with my RX480 as well as on Solus I guess it is not a problem of Snap, but maybe of mesa or the compiler suites? I've found that the snap package prefers OpenGL4.4 as can be seen here https://pastebin.com/jYzQmPeR on my Solus install and here https://pastebin.com/EZjSnkL3 on my Arch install with different errors and dumps.

Anyone got it running on a RX480/RX580? If yes, on which distro, version of mesa or with what special settings?

DamonLinuxPL commented on 23 February 2018 at 4:27 pm UTC

Just testing it on Ubuntu 17.10 - no issue, game launch fine.
Tested also on OpenMandriva LX3.03 - no issue. Same on Mageia 6. Using mesa 17.3.

skyrrd commented on 23 February 2018 at 6:51 pm UTC

Ok nice to know and thanks for testing.
So far it's working on Debian, Ubuntu, openmandriva, maegia, Solus, mint and gentoo.

Guess we'll rather make a list of not working distributions?

GloriousEggroll commented on 26 February 2018 at 6:33 am UTC

just some info, I went to test it again today on arch via snap. I updated snapd-git from the aur, launched the game, and it ran but then froze.

I then changed the overrides from
MESA_GL_VERSION_OVERRIDE=4.4 MESA_GLSL_VERSION_OVERRIDE=440 %command%
to
MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 %command%

game's running so far without a hitch. I wonder if the override needs to match mesa's core profile.

I'm currently on mesa 18 rc4 with a vega 64.

glxinfo:

[gloriouseggroll@shittywok ~]$ glxinfo | grep "OpenGL"
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX Vega (VEGA10 / DRM 3.23.0 / 4.16.0-rc2-g91ab883eb213, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc4 (git-719f2c9340)
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc4 (git-719f2c9340)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0-rc4 (git-719f2c9340)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

kaymio commented on 28 February 2018 at 4:14 pm UTC

skyrrdOk nice to know and thanks for testing.
So far it's working on Debian, Ubuntu, openmandriva, maegia, Solus, mint and gentoo.

Guess we'll rather make a list of not working distributions?

Do you have a Nvidia card? The problem seems to persist in Solus (native/snap) as well as on Arch (runtime/snap) with a RX480.
The only distro I could get in running on was Ubuntu 17.10. Not an ideal choice as the 18.04 LTS version wants to spy on you during the install process.

riusma commented on 28 February 2018 at 6:13 pm UTC

kaymioThe only distro I could get in running on was Ubuntu 17.10. Not an ideal choice as the 18.04 LTS version wants to spy on you during the install process.

Opt-in if you upgrade from 17.10 or 16.04...

Quote”Upgrading users would need to purposely “opt-in” to this behaviour, as that wasn’t
explicitly asked in the past.

Dustin Kirkland

  Go to:

Due to spam you need to Register and Login to comment.


Or login with...

Livestreams & Videos
Community Livestreams
  • Story Time: „The Secret of Monkey Island“
  • Date:
See more!
Popular this week
View by Category
Contact
Latest Comments
Latest Forum Posts