You can sign up to get a daily email of our articles, see the Mailing List page!
Seems like Nvidia Driver is not perfect installed (glitches in Prey)
Page: 1/3»
  Go to:
Spirimint 3 Oct

Razer Blade Stealth 2020, Intel Core i7-1065G7 16 GB RAM nVidia GeForce GTX 1650 Ti.

Linux Distribution: Ubuntu 20.04 LTS
Desktop Environment: KDE Plasma
Graphics Card: nVidia GeForce GTX 1650 Ti with max Q
GPU Driver Version: 450.66.0

Have you checked for system updates?: [Yes]

If this is to do with Steam, please add your system read-out from Steam -> Help -> System Information https://pastebin.com/pbPvgeZ2


You can note your issue below here


Hey guys,
i installed Kubuntu 20 on a new Razer Blade Stealth 2020.
Intel Core i7-1065G7 16 GB RAM nVidia GeForce GTX 1650 Ti.

Everything seem to work. But when i move the mouse in for example Prey. The textures pops up like glitches.
I guess its the Nvidia Graphic Driver. I installed the driver on different ways. Same result.
My driver version : 450.66.0 (also tried the newest 455)
Vulkan: 1.2.133
Proton 5.

Is thery any tool i try out if the card works correct?


Edit: ok i tried now vkcube and i guess the cube should be turn around smooth but its stuck on one place and tried to turn without succes and it creates kind of the same texture popup as i have in prey. So i guess there so something wrong with vulkan.

Also found another error:

lspci | grep 3D && vulkaninfo | grep deviceName
58:00.0 3D controller: NVIDIA Corporation Device 1f95 (rev a1)
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
deviceName = GeForce GTX 1650 Ti with Max-Q Design

Last edited by Spirimint on 7 October 2020 at 7:59 pm UTC

whizse 4 Oct
  • Supporter

Quoting: SpirimintAlso found another error:

lspci | grep 3D && vulkaninfo | grep deviceName
58:00.0 3D controller: NVIDIA Corporation Device 1f95 (rev a1)
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
deviceName = GeForce GTX 1650 Ti with Max-Q Design
At least those are normal and a non-issue. The vulkaninfo binary is 64bit and won't load the 32bit version of the vulkan drivers. I get the same errors on my system.

Spirimint 4 Oct

just got this tip, from another forum and it just works!

https://ubuntuforums.org/showthread.php?t=2450147&p=13985186#post13985186

Can anybody explain,bwhy it worked? Whats the diffetence compare to normal driver install?

Last edited by Spirimint on 4 October 2020 at 10:50 pm UTC

Redface 5 Oct

Quoting: Spirimintjust got this tip, from another forum and it just works!

https://ubuntuforums.org/showthread.php?t=2450147&p=13985186#post13985186

Can anybody explain,bwhy it worked? Whats the diffetence compare to normal driver install?

It is actually more or less the normal install in Ubuntu, you just get the packages form the semi-official PPA instead of the Ubuntu repositories. For 450 its currently the same version, so probably did not make the difference.

Else it describes to use the on-demand mode, where the Intel GPU is used for the desktop and all programs as default, unless you start it in the way described there. But you could also just right click on the icon and choose run on dedicated graphic card.

In optimus laptops, which I assume yours is, since most laptops with Nvidia are, you can choose between 3 modes (and that is not dependant on the PPA, it comes so in Ubuntu and most other distros now)

Power saving - Intel GPU only, use it when on battery and not interest in using the Nvidia GPU

Performance Mode - Nvidia GPU only, use it when plugged in, and for some models the HDMI output only works then, and you want to use the nvidia often, or have to because of

On Demand Mode - Intel GPU is used for the desktop and all programs as default, unless you start them as described there or
use the right click menu, and there could be m ore ways.

You can switch between those modes with the prime-select command, the nvidia-settings app, or the mate-optimus applet (which also works in Gnome)

Did you check before when you had problems if you actually where using the Nvidia GPU, with Nvidia settings , the command or the applet?

Spirimint 5 Oct

Ok, well i tried i guess 20 times to install the driver with the official ppa. I also could change between the modes but vulkan only working now.

But good to know its more or less the same. So maybe something wrong in the official one. I still will keep it in mind if i have again some probs with the official way :)

Just asked to get better in linux :)

Nasra 6 Oct

Before working on possibly mysfunctionnal drivers, did you change the proton version and test with another ?

In my case, No Man's Sky don't really like Proton version up to 5.0.9 (it causes crashes and glitches).

Last edited by Nasra on 6 October 2020 at 6:24 am UTC

Spirimint 6 Oct

Yeah i tried different proton version, but the glitches where still there.

Spirimint 7 Oct

Ok its really strange, If i play Linux Native games i need "performance mode" and for vulkan i need to change to "on demand"

Redface 8 Oct

Quoting: SpirimintOk its really strange, If i play Linux Native games i need "performance mode" and for vulkan i need to change to "on demand"
There are also Linux native games that use vulkan, do you mean proton with vulkan?

Do you right click and choose use dedicated graphic card or the environment variables to launch the games with nvidia when you use on demand mode? If not then you use the Intel GPU, and that points to that you have something missing with vulkan for nvidia but have it correctly installed for Intel. If yoiu did not try any Linux native vulkan games in performance mode and they worked there.



What happens if you run vkcube a vulkan demo with a spinning cube in performance mode?


What does

 
apt list --installed|grep -i nvidia


show

and

 
gpu-manager


both in on demand and in performance mode? It will show what ubuntu finds of GPUs and how they are used.

Spirimint 8 Oct

Ah yes i mean Proton with Vulkan.

If i try "vkcube" in performance mode o got a black windows. The cube only spins in "on demand" mode.

QuoteDo you right click and choose use dedicated graphic card or the environment variables to launch the games with nvidia when you use on demand mode? If not then you use the Intel GPU, and that points to that you have something missing with vulkan for nvidia but have it correctly installed for Intel. If yoiu did not try any Linux native vulkan games in performance mode and they worked there.

not sure how i can do that.


 
apt list --installed|grep -i nvidia

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libnvidia-cfg1-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-common-450/focal-updates,focal-updates,focal,focal,now 450.66-0ubuntu0.20.04.1 all  [installiert]
libnvidia-compute-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-compute-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
libnvidia-decode-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-decode-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
libnvidia-encode-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-encode-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
libnvidia-extra-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-fbc1-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-fbc1-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
libnvidia-gl-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-gl-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
libnvidia-ifr1-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
libnvidia-ifr1-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 i386  [Installiert,automatisch]
nvidia-compute-utils-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
nvidia-dkms-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
nvidia-driver-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [installiert]
nvidia-kernel-common-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
nvidia-kernel-source-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
nvidia-prime/focal,focal,now 0.8.14 all  [installiert]
nvidia-settings/focal-updates,focal,now 440.82-0ubuntu0.20.04.1 amd64  [installiert]
nvidia-utils-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]
xserver-xorg-video-nvidia-450/focal-updates,focal,now 450.66-0ubuntu0.20.04.1 amd64  [Installiert,automatisch]


 
gpu-manager
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.8.14-xanmod1/updates/dkms
Found nvidia module: nvidia.ko
Looking for amdgpu modules in /lib/modules/5.8.14-xanmod1/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:8a52
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:1f95
BusID "PCI:88@0:0:0"
Is boot vga? no
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card1", driven by "nvidia-drm"
Found "/dev/dri/card0", driven by "i915"
output 0:
        card0-eDP-1
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
I couldn't open /var/lib/ubuntu-drivers-common/last_gfx_boot for writing.
Error: can't write to /var/lib/ubuntu-drivers-common/last_gfx_boot


Last edited by Spirimint on 8 October 2020 at 8:18 pm UTC

Redface 12 Oct

Look like you have all packages installed, and sorry about the late answer.

On demand is to use the Intel GPU for all, except those you run with the right click to choose dedicated graphic card, or use the script from the forum you linked.

So Nvidia does work except for vulkan. there was a bug a while ago that some file had wrong contents, maybe that happened to you.

See https://askubuntu.com/questions/967335/vulkan-does-not-work

What does /usr/share/vulkan/icd.d/nvidia_icd.json look like on your system:

Mine is

 
{
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "libGLX_nvidia.so.0",
        "api_version" : "1.2.133"
    }
}

The important part is that its libGLX_nvidia.so.0 and not libGL.so.1
the version number will change over time.

I have above file with the 450 driver

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Latest Forum Posts