Join us on our own very special Reddit: /r/Linuxers
Aquanox Deep Descent is out. Native version a possibility?
Page: «2/4»
  Go to:
Shmerl 25 Oct, 2020

Also, did you try it with vkd3d fork? I see the game has DX12 renderer too.

Just bought the game, I'll try with vkd3d-proton.

Last edited by Shmerl on 25 October 2020 at 2:10 am UTC

Avehicle7887 25 Oct, 2020

Quoting: ShmerlAlso, did you try it with vkd3d fork? I see the game has DX12 renderer too.

Just bought the game, I'll try with vkd3d-proton.

I've only tried with dxvk. Been a while since I compiled vkd3d since I don't have much use for it (yet).

As for Aquanox I recorded some gameplay yesterday: https://www.youtube.com/watch?v=mMptKYsaxp4

Shmerl 26 Oct, 2020

In case anyone needs, I made a script for building vkd3d-proton.

Last edited by Shmerl on 26 October 2020 at 1:06 am UTC

Shmerl 26 Oct, 2020

Did you notice something off with this Wine staging version? It creates files on my btrfs volume with all attributes set (that's from GOG installer for Aquanox Deep Descent)

rwxrwxrwx

Weird.

Shmerl 26 Oct, 2020

Hm, how do you switch to DX12 renderer in the game? I don't see such option.

UPDATE:

I figured, you need to run

wine ANX.exe -dx12

It picks vkd3d but crashes on startup. I'll file a bug.

Last edited by Shmerl on 26 October 2020 at 3:25 am UTC

Shmerl 26 Oct, 2020

Quoting: Avehicle7887only overrides used are nvapi64 (set to disabled) and the usual dxgi + d3d11 to enable dxvk.

How did you figure out it needs disabling nvapi?

Shmerl 26 Oct, 2020

Also the language is messed up after installation. How do you select English?

UPDATE:

OK, I figure out how to change the language, it's in the settings.

Last edited by Shmerl on 26 October 2020 at 4:06 am UTC

Shmerl 26 Oct, 2020

Half of the time the game doesn't start though. I need to kill it an try again, sometimes it starts.

Avehicle7887 26 Oct, 2020

Quoting: Shmerl
Quoting: Avehicle7887only overrides used are nvapi64 (set to disabled) and the usual dxgi + d3d11 to enable dxvk.

How did you figure out it needs disabling nvapi?

I didn't, I just made it a habit to disable it by default for all games.

Quoting: ShmerlHalf of the time the game doesn't start though. I need to kill it an try again, sometimes it starts.

I don't know if it helps, have you tried to limit the game to a limited set of cores? I read somewhere that the mfplat patches don't play nice with high thread count.

While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

We have no adverts, no paywalls, no timed exclusive articles. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.

Livestreams & Videos
Community Livestreams
Latest Forum Posts